Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Android Новый топик    Ответить
 Комбинация версий в файле build.gradle  [new]
Warl0ck_01
Member

Откуда:
Сообщений: 14
Есть приложение, написанное на более ранних версиях SDK и Android Studio. Необходимо его запустить на стандартном эмуляторе в Android Studio 2.3.3.
Но не получается собрать - подчеркивается строка compile 'com.android.support:appcompat-v7:23.2.0' в файле build.gradle
Вот содержимое файла build.gradle:
apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion '23.0.2'
    defaultConfig {
        applicationId "com.scalable.app"
        minSdkVersion 14
        targetSdkVersion 14

       testApplicationId "com.scalable.app.tests"
       testInstrumentationRunner "android.test.InstrumentationTestRunner"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
        }
    }
    productFlavors {
    }
}

dependencies {
    compile 'com.google.code.gson:gson:1.7.1'
    compile 'com.google.android.gms:play-services:8.4.0'
    compile 'com.squareup:tape:1.2.3'
    compile 'com.android.support:appcompat-v7:23.2.0'
}


Не могу понять что хочет студия? подчеркивается строка compile 'com.android.support:appcompat-v7:23.2.0' в файле build.gradle и красным отображается элемент R.drawable.ic_polymer_white.

Уже кучу вариантов комбинаций перебрал, но пока не завелось
22 июн 17, 17:26    [20584308]     Ответить | Цитировать Сообщить модератору
 Re: Комбинация версий в файле build.gradle  [new]
Petro123
Member

Откуда: Загрузочный сектор Москвы (AutoPOI.ru)
Сообщений: 33048
Warl0ck_01,
targetSdkVersion поставить последнюю. У вас 23.
Версии градле тоже самые последнии.
Т.е. как бы открыть проект на самых новых версиях.
На прошлых и старых нет смысла.
22 июн 17, 17:49    [20584381]     Ответить | Цитировать Сообщить модератору
 Re: Комбинация версий в файле build.gradle  [new]
Petro123
Member

Откуда: Загрузочный сектор Москвы (AutoPOI.ru)
Сообщений: 33048
Т.е. compat библиотека тоже последнюю поставить
22 июн 17, 18:58    [20584535]     Ответить | Цитировать Сообщить модератору
Все форумы / Android Ответить