Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft Office Новый топик    Ответить
 Итоги для умной таблицы  [new]
ferzmikk
Member

Откуда:
Сообщений: 984
Здравствуйте!

У умной таблицы есть возможность выводить итог. Но в данном случае как в скриншоте в итоге должны быть две меры. Показывать один итог сразу по двум мерам это не логично.

Таблица динамическая, то есть после обновления может изменяться количество строк и количество столбцов-дат.

Поверх умной таблицы написал формулы, которые должны показывать такие суммы. Суммы показывает. Но решение не оптимальное. Количество строк и столбцов-дат меняется. В формуле указал диапазоны ячеек, а не колонок.

Подскажите, для данной задачи как правильно формулы прописать? Может быть у умной таблицы есть какие то возможности для решения данной задачи?

К сообщению приложен файл. Размер - 56Kb
25 сен 17, 09:36    [20819737]     Ответить | Цитировать Сообщить модератору
 Re: Итоги для умной таблицы  [new]
ferzmikk
Member

Откуда:
Сообщений: 984


К сообщению приложен файл (Итоги для умной таблицы.xlsx - 10Kb) cкачать
25 сен 17, 09:37    [20819740]     Ответить | Цитировать Сообщить модератору
 Re: Итоги для умной таблицы  [new]
F
Guest
Есть функция Промежуточные.Итоги как раз для этих целей. Она работает с неизвестным заранее числом строк.
25 сен 17, 11:11    [20820007]     Ответить | Цитировать Сообщить модератору
 Re: Итоги для умной таблицы  [new]
ferzmikk
Member

Откуда:
Сообщений: 984
F
Есть функция Промежуточные.Итоги как раз для этих целей. Она работает с неизвестным заранее числом строк.
Получается тут надо совмещать функции СУММЕСЛИ и ПРОМЕЖУТОЧНЫЕ.ИТОГИ.
25 сен 17, 11:35    [20820099]     Ответить | Цитировать Сообщить модератору
 Re: Итоги для умной таблицы  [new]
ferzmikk
Member

Откуда:
Сообщений: 984
Делаю через структурированные формулы. Получилась такая формула
=СУММЕСЛИ(Таблица2[Мера];$B2;Таблица2[01.08.17])

Как в первом аргументе функции колонку сделать как абсолютную ссылку в структурированной формуле, чтобы не смещалась при протягивании формул?
25 сен 17, 14:02    [20820680]     Ответить | Цитировать Сообщить модератору
 Re: Итоги для умной таблицы  [new]
ferzmikk
Member

Откуда:
Сообщений: 984
В структурированную формулу возможно вставить абсолютную ссылку?
26 сен 17, 07:31    [20822357]     Ответить | Цитировать Сообщить модератору
 Re: Итоги для умной таблицы  [new]
ferzmikk
Member

Откуда:
Сообщений: 984
Не понятно, почему такая формула не работает
=СУММЕСЛИ(Таблица2[Мера];$B2;ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;Таблица2[01.08.17]))
26 сен 17, 10:18    [20822709]     Ответить | Цитировать Сообщить модератору
 Re: Итоги для умной таблицы  [new]
ferzmikk
Member

Откуда:
Сообщений: 984
В общем, у меня получилось без использования сруктурированных формул
=СУММПРОИЗВ(($B$6:$B$25=$B2)*ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(C$6;СТРОКА(C$6:C$25)-СТРОКА(C$6);СТОЛБЕЦ(C$6:C$25)-СТОЛБЕЦ(C$6))))
Потом протянул формулы вниз и направо. Формулы работают.

Учитывая, что формулу вставляет макрос с определением количеством строк в таблице.

Не слишком ли сложная получилась формула? Можно ли было упростить?

К сообщению приложен файл (Итоги для умной таблицы.xlsx - 10Kb) cкачать
27 сен 17, 11:21    [20826173]     Ответить | Цитировать Сообщить модератору
 Re: Итоги для умной таблицы  [new]
ferzmikk
Member

Откуда:
Сообщений: 984
Для строк:
=СУММПРОИЗВ(($B$6:$B$25=$B2)*ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(C$6;СТРОКА(C$6:C$25)-СТРОКА(C$6);СТОЛБЕЦ(C$6:C$25)-СТОЛБЕЦ(C$6))))
Для столбцов
=СУММПРОИЗВ(($B$6:$B$25=$B2)*ПРОМЕЖУТОЧНЫЕ.ИТОГИ(9;СМЕЩ(C$6;СТРОКА(C$6:C$25)-СТРОКА(C$6);СТОЛБЕЦ(C$6:C$25)-СТОЛБЕЦ(C$6))))
Зачем в аргументе функции разность? Они все равно равны. Хотя без них формула не работает?
27 сен 17, 11:32    [20826225]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft Office Ответить