Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft Office Новый топик    Ответить
 Протянуть формулу  [new]
ferzmikk
Member

Откуда:
Сообщений: 1075
Здравствуйте!

Во вложенном файле присутствует основная таблица. Из этой таблицы строится другая таблица, прописываются формулы. Логика формул видна из второго скриншота.

Как протягивать формулу для остальных дней и при этом сохраняя логику прописанных формул?

К сообщению приложен файл. Размер - 10Kb
14 ноя 17, 09:37    [20951393]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
ferzmikk
Member

Откуда:
Сообщений: 1075
С отображением формул

К сообщению приложен файл. Размер - 11Kb
14 ноя 17, 09:38    [20951396]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
ferzmikk
Member

Откуда:
Сообщений: 1075
Вложенный файл

К сообщению приложен файл (Книга2.xlsx - 8Kb) cкачать
14 ноя 17, 09:40    [20951399]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
Akina
Member

Откуда: Зеленоград, Москва, Россия
Сообщений: 16189
=ДВССЫЛ("R" & (2+ОСТАТ((СТОЛБЕЦ()-2);4)) & "C" & ЦЕЛОЕ((6+СТОЛБЕЦ())/4);ЛОЖЬ)
14 ноя 17, 09:55    [20951462]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
ferzmikk
Member

Откуда:
Сообщений: 1075
Akina,

Спасибо!
14 ноя 17, 09:58    [20951472]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
ferzmikk
Member

Откуда:
Сообщений: 1075
Akina
=ДВССЫЛ("R" & (2+ОСТАТ((СТОЛБЕЦ()-2);4)) & "C" & ЦЕЛОЕ((6+СТОЛБЕЦ())/4);ЛОЖЬ)
Пытаюсь преобразовать формулу, если вторая табличка будет ниже и правее. Откуда 6 взялось? Это ориентир на первую меру второй даты?
14 ноя 17, 10:41    [20951669]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
Alibek B.
Member

Откуда:
Сообщений: 2483
Во-первых, включить режим R1C1.
Во-вторых, ДВССЫЛ с формулами в данном случае глупость. Для таких задач (поиск в таблице) есть функции типа ВПР/ГПР/ИНДЕКС.
14 ноя 17, 11:06    [20951761]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
Akina
Member

Откуда: Зеленоград, Москва, Россия
Сообщений: 16189
ferzmikk
Откуда 6 взялось?

Если вторую таблицу сдвинуть на N столбцов вправо, то надо уменьшить это число на N.
А то, что ниже - не влияет.
14 ноя 17, 11:20    [20951819]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
Akina
Member

Откуда: Зеленоград, Москва, Россия
Сообщений: 16189
Alibek B.
ДВССЫЛ с формулами в данном случае глупость. Для таких задач (поиск в таблице) есть функции типа ВПР/ГПР/ИНДЕКС.
Сделаешь?
14 ноя 17, 11:20    [20951822]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
Казанский
Member

Откуда:
Сообщений: 1065
ferzmikk, вариант: для дат
=ИНДЕКС(1:1;(СТОЛБЕЦ()+6)/4)

для значений
=ИНДЕКС($B$2:$H$5;1+ОСТАТ((СТОЛБЕЦ()+2);4);(СТОЛБЕЦ()+2)/4)


К сообщению приложен файл (Книга2 (6).xlsx - 9Kb) cкачать
14 ноя 17, 11:42    [20951975]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
Alibek B.
Member

Откуда:
Сообщений: 2483
Akina
Сделаешь?

ТС просил подсказку, а не готовое решение.
Описания указанных функций достаточно, чтобы он сделал сам.
14 ноя 17, 11:51    [20952032]     Ответить | Цитировать Сообщить модератору
 Re: Протянуть формулу  [new]
ferzmikk
Member

Откуда:
Сообщений: 1075
Получилась такая и чтоб можно двигать правее и ниже. Только нужно указать, где начинается ячейка вывода.
=ИНДЕКС($B$2:$H$5;ОСТАТ(СТОЛБЕЦ()-СТОЛБЕЦ($B$10);4)+1;ЦЕЛОЕ((СТОЛБЕЦ()-СТОЛБЕЦ($B$10)+4)/4))
15 ноя 17, 21:59    [20958038]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft Office Ответить