Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft Office Новый топик    Ответить
 Формула в exel  [new]
tuandreeva
Member

Откуда: Самара
Сообщений: 749
Подскажите, как найти процентное соотношение 2-х чисел в exel.
Например:
A2=5.02
D4=8.01
F7=A2/D4*100
а какие еще формулы есть, d4 может быть 0, а на 0 делить нельзя
И F7 должно выглядеть так 62,67%
5 июн 07, 11:48    [4230697]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Deggasad
Member

Откуда: Воронеж
Сообщений: 3490
Это формула:
=Если(D4=0;0;A2/D4)
А формат ячейки процентный поставь!
5 июн 07, 12:01    [4230843]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
tuandreeva
Member

Откуда: Самара
Сообщений: 749
=ЕСЛИ(B10=0;0;B10/B13)
Есть формула, в ней ссылка на В13 всегда остатется, а все остальное меняется:
=ЕСЛИ(B11=0;0;B11/B13)
=ЕСЛИ(B12=0;0;B12/B13) и т.д.
Как автозаполнением можно это сделать? После автозаполнения В13, в14, в15....
5 июн 07, 15:26    [4232328]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Deggasad
Member

Откуда: Воронеж
Сообщений: 3490
tuandreeva
=ЕСЛИ(B10=0;0;B10/B13)
Есть формула, в ней ссылка на В13 всегда остатется, а все остальное меняется:
=ЕСЛИ(B11=0;0;B11/B13)
=ЕСЛИ(B12=0;0;B12/B13) и т.д.
Как автозаполнением можно это сделать? После автозаполнения В13, в14, в15....


=ЕСЛИ(B10=0;0;B10/$B$13)
5 июн 07, 15:32    [4232379]     Ответить | Цитировать Сообщить модератору
Между сообщениями интервал более 1 года.
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10
Добрый день помогите кто может с формулой.

В ячейке может быть сумма представленная в рублях, либо в долларах, либо в евро. И мне необходимо в этих ячейках прописать такую формулу, которая будет в рядом стоящей ячейке считать сумму в долларах.

Заранее всем спасибо.
16 июл 08, 11:53    [5940700]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Deggasad
Member

Откуда: Воронеж
Сообщений: 3490
Пример в студию (файл)
16 июл 08, 12:59    [5941290]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10
в колонке под названием "Коммерческие условия" проставлены стоимости с комментариями, а рядом в пустой колонке нужно чтоб они приобразовывали свои значения в долларах.
16 июл 08, 13:09    [5941351]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10


К сообщению приложен файл (Таблица по объектам.zip - 15Kb) cкачать
16 июл 08, 13:10    [5941357]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Deggasad
Member

Откуда: Воронеж
Сообщений: 3490
Большая часть народа все ещё пользуется 2003 Эксель, и думаю это не скоро изменится, так что даёшь XLS?
16 июл 08, 18:04    [5944230]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10
Даю

К сообщению приложен файл (Таблица по объектам.zip - 15Kb) cкачать
16 июл 08, 18:10    [5944290]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Deggasad
Member

Откуда: Воронеж
Сообщений: 3490
Ну и что ты дал ? :))
16 июл 08, 18:43    [5944484]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10
Как что?! Прикрепил заархивированный файл в котором надо формулу прописать!
17 июл 08, 09:36    [5945895]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Deggasad
Member

Откуда: Воронеж
Сообщений: 3490
Fisa
Как что?! Прикрепил заархивированный файл в котором надо формулу прописать!

ну открой посмотри, там опять в формате 2007 Экселя
17 июл 08, 10:28    [5946219]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10
Ну пардон! Держи!

К сообщению приложен файл (Таблица по объектам 1.zip - 10Kb) cкачать
17 июл 08, 10:37    [5946295]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Deggasad
Member

Откуда: Воронеж
Сообщений: 3490
Это почти нереально. Нужна какая-то однородная информация чтобы её обрабатывать
ну или хотя бы какая-то логика по которой эту строку можно расшифровать.
А так получатеся нужно выбрать отдельно число - это можно (при условии что оно одно, а не интервал и стоит впереди желательно)
Потом выбрать единицу измерения (если знать где она стоит - например сразу за числом)
Потом в соответсвии с единицой измерения изменить число на соответсвующие курсы (для этого отдельно нужен справочник соотношения валют)
После чего ещё нужно посмотреть с НДС или без НДС (например найти слово НДС и посмотреть какое слово перед ним) и в соответсвии с этим привести к одному виду или сделать пометку. причём если про НДС не указано. то нужно знать что по умолчанию.
После чего представить в желаемом виде

Короче не так просто и состоит из нескольких подзадач, а результат не 100%
Поэтому стоит ли заморачиваться?
17 июл 08, 11:57    [5946911]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10
Мда... Скажу об этом шефу, пусть пальцами считает.
А тебе спасибо за помощь))))
17 июл 08, 12:08    [5947033]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Deggasad
Member

Откуда: Воронеж
Сообщений: 3490
Fisa
Мда... Скажу об этом шефу, пусть пальцами считает.
А тебе спасибо за помощь))))


Вот пример варианта для частного случая

К сообщению приложен файл (Таблица по объектам.zip - 11Kb) cкачать
17 июл 08, 13:14    [5947729]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10
Во абра-кадабра получилась! Здорово!
А подскажи в случае изменения курса как считать?
17 июл 08, 13:22    [5947789]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10
Для рублевых значений формула не работает

К сообщению приложен файл (Таблица по объектам.zip - 11Kb) cкачать
17 июл 08, 15:36    [5949100]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Fisa
Member

Откуда:
Сообщений: 10
Скажи, может у тебя ася есть? так проще будет поговорит!
17 июл 08, 16:00    [5949280]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
Deggasad
Member

Откуда: Воронеж
Сообщений: 3490
Fisa
Для рублевых значений формула не работает

р/кв.м
а не руб./кв.м

Можно для любого случая придумать, но это уже нужно конкретно подходить
18 июл 08, 00:11    [5951119]     Ответить | Цитировать Сообщить модератору
Между сообщениями интервал более 1 года.
 Re: Формула в exel  [new]
stish
Member

Откуда:
Сообщений: 1
Помогите пожалуйста с формулой в Exel
Xo=0.4 dx=0.4

F(x)=b/tg(d*x в квадрате /с)+с*корень|a*x|

a=-1.1
b=0.6
c=2
d=0.8

n=20 Xi+1=Xi+DX
26 янв 11, 13:09    [10133690]     Ответить | Цитировать Сообщить модератору
 Re: Формула в exel  [new]
big-duke
Member

Откуда:
Сообщений: 6353
stish,
Модератор:
давайте-ка в отдельный топик.
.
26 янв 11, 13:09    [10133698]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft Office Ответить