Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Архив ПТ Новый топик    Ответить
Топик располагается на нескольких страницах: [1] 2 3   вперед  Ctrl      все
 Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148427
... отсутствующих на sql.ru.
Казалось бы, все слова русского языка перебраны в многомегабайтных обсуждениях, трёпах и срачах.
Ан нет. Например, не нашёл слова "морфема".
15 сен 08, 14:39    [6185696]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
Doomaty
Member

Откуда: CПб
Сообщений: 43785
IT-Клоп
... отсутствующих на sql.ru.
Казалось бы, все слова русского языка перебраны в многомегабайтных обсуждениях, трёпах и срачах.
Ан нет. Например, не нашёл слова "морфема".

не прафда зашёл в поиск, нашёл
15 сен 08, 14:40    [6185699]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
HTTP
Member

Откуда:
Сообщений: 8783
Doomaty
не прафда зашёл в поиск, нашёл

и не 1 раз даже!!!
15 сен 08, 14:41    [6185706]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
идиоты
Member

Откуда: какая красавица эта кукурузочка
Сообщений: 12217
Процедура УдалитьДвиженияРегистратора(ДокументОбъект, Отказ, СтруктураВидовУчета = Неопределено, ОчищатьРегистры = Истина) Экспорт
	
	МассивОбрабатываемыхСтрокТаблицыДвижений = Новый Массив();
	
	РегистрыКБезусловномуУдалению = ОпределитьСписокРегистровСБезусловнымУдалениемДвижений(ДокументОбъект.Ссылка);
	
	// получение списка регистров, по которым существуют движения
	ТаблицаДвижений = ПолныеПрава.ОпределитьНаличиеДвиженийПоРегистратору(ДокументОбъект.Ссылка);
	
	Если ОчищатьРегистры Тогда
		ТаблицаДвижений.Колонки.Добавить("НаборЗаписей");
		ТаблицаДвижений.Колонки.Добавить("БезусловноеУдаление", Новый ОписаниеТипов("Булево"));
			
		Для Каждого СтрокаДвижения ИЗ ТаблицаДвижений Цикл
			// имя регистра передается как значение, полученное с помощью
			// функции ПолноеИмя() метаданных регистра
			ПозицияТочки = Найти(СтрокаДвижения.Имя, ".");
			ТипРегистра = Лев(СтрокаДвижения.Имя, ПозицияТочки - 1);
			ИмяРегистра = СокрП(Сред(СтрокаДвижения.Имя, ПозицияТочки + 1));
			
			// необходимо очищать только те регистры, которые относятся к видам учета по которым перепроводиться документ
			Если (НЕ СтруктураВидовУчета = Неопределено) И (ТипЗНЧ(СтруктураВидовУчета) = Тип("Структура")) Тогда
				Если НЕ ОпределитьПринадлежностьРегистраКВидамУчета(ИмяРегистра, СтруктураВидовУчета) Тогда
					Продолжить;
				КонецЕсли;
			КонецЕсли;	
			
			МассивОбрабатываемыхСтрокТаблицыДвижений.Добавить(СтрокаДвижения);
			
			Если (НЕ РегистрыКБезусловномуУдалению = Неопределено) И РегистрыКБезусловномуУдалению.Свойство(ИмяРегистра) Тогда
				СтрокаДвижения.БезусловноеУдаление = Истина;
				Набор = ИмяРегистра;
			Иначе		
				
				ЕСли ТипРегистра = "РегистрНакопления" Тогда
					МетаданныеНабора = Метаданные.РегистрыНакопления[ИмяРегистра];
					Набор = РегистрыНакопления[ИмяРегистра].СоздатьНаборЗаписей();
						
				ИначеЕсли ТипРегистра = "РегистрБухгалтерии" Тогда
					МетаданныеНабора = Метаданные.РегистрыБухгалтерии[ИмяРегистра];
					Набор = РегистрыБухгалтерии[ИмяРегистра].СоздатьНаборЗаписей();
						
				ИначеЕсли ТипРегистра = "РегистрСведений" Тогда
					МетаданныеНабора = Метаданные.РегистрыСведений[ИмяРегистра];
					Набор = РегистрыСведений[ИмяРегистра].СоздатьНаборЗаписей();
						
				ИначеЕсли ТипРегистра = "РегистрРасчета" Тогда
					МетаданныеНабора = Метаданные.РегистрыРасчета[ИмяРегистра];
					Набор = РегистрыРасчета[ИмяРегистра].СоздатьНаборЗаписей();
						
				КонецЕсли;
					
				Если НЕ ПравоДоступа("Изменение", МетаданныеНабора) Тогда
					// отсутствуют права на всю таблицу регистра
					СообщитьОбОшибке("Нарушение прав доступа", Отказ, СтрокаДвижения.Имя);
					Возврат;
				КонецЕсли;
					
				Набор.Отбор.Регистратор.Установить(ДокументОбъект.Ссылка);			
			КонецЕсли;	
			// набор не записывается сразу, чтобы не откатывать транзакцию, если впоследствии
			// выяснится, что на один из регистров не хватает прав.		
			СтрокаДвижения.НаборЗаписей = Набор;		
			
		КонецЦикла;	
			
		Для Каждого СтрокаДвижения ИЗ МассивОбрабатываемыхСтрокТаблицыДвижений Цикл		
			Если СтрокаДвижения.БезусловноеУдаление Тогда
				ПолныеПрава.ЗаписатьНаборЗаписейНаСервере(СтрокаДвижения.НаборЗаписей, ДокументОбъект.Ссылка);
			Иначе		
				Попытка
					СтрокаДвижения.НаборЗаписей.Записать();
				Исключение
					// возможно «сработал» RLS или механизм даты запрета изменения
					СообщитьОбОшибке(ОписаниеОшибки(), Отказ, СтрокаДвижения.Имя);
					ВызватьИсключение "Операция не выполнена";
				КонецПопытки;
			КонецЕсли;	
		КонецЦикла;
			
	Иначе
		Для Каждого СтрокаДвижения ИЗ ТаблицаДвижений Цикл
			// имя регистра передается как значение, полученное с помощью
			// функции ПолноеИмя() метаданных регистра
			ПозицияТочки = Найти(СтрокаДвижения.Имя, ".");
			ИмяРегистра = СокрП(Сред(СтрокаДвижения.Имя, ПозицияТочки + 1));
			ДокументОбъект.Движения[ИмяРегистра].Очистить();
		КонецЦикла;	
	КонецЕсли;
	
	//Если требуется очищать регистры, то нужно проверять количество записей в наборе перед очисткой
	ОчисткаКоллекцииДвиженийДокумента(ДокументОбъект);
	
	// Удаление записей регистрации из всех последовательностей
	ОбщегоНазначения.УдалитьРегистрациюДокументаВПоследовательностях(ДокументОбъект, Истина);
	
КонецПроцедуры
15 сен 08, 14:41    [6185707]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148427
теперь-то конечно нашёл.
15 сен 08, 14:41    [6185708]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148427
выигранное слово появляеццо впервые только в топике "Игра: поиск слов"
15 сен 08, 14:43    [6185718]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
akopium
Member

Откуда: Донецк
Сообщений: 1246
IT-Клоп
... отсутствующих на sql.ru.

гамета
15 сен 08, 14:43    [6185723]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
RSman
Member

Откуда: Тромавиль
Сообщений: 2732
престидижитатор
15 сен 08, 14:43    [6185724]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
commit;
Member

Откуда: SQL92
Сообщений: 47330
IT-Клоп
... отсутствующих на sql.ru.
Казалось бы, все слова русского языка перебраны в многомегабайтных обсуждениях, трёпах и срачах.
Ан нет. Например, не нашёл слова "морфема".


трипонема
15 сен 08, 14:43    [6185725]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
RSman
Member

Откуда: Тромавиль
Сообщений: 2732
партсъезд
15 сен 08, 14:45    [6185731]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
C#C++
Member [заблокирован]

Откуда: Суровые северные земли
Сообщений: 2636
говноедство
15 сен 08, 14:45    [6185734]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
C#C++
Member [заблокирован]

Откуда: Суровые северные земли
Сообщений: 2636
C#C++
говноедство
Искал по всем форумам, с учетом морфологии
15 сен 08, 14:46    [6185740]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
commit;
Member

Откуда: SQL92
Сообщений: 47330
Акузяка
15 сен 08, 14:46    [6185741]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148427
commit;
IT-Клоп
... отсутствующих на sql.ru.
Казалось бы, все слова русского языка перебраны в многомегабайтных обсуждениях, трёпах и срачах.
Ан нет. Например, не нашёл слова "морфема".


трипонема


она пишеццо как трепонема и уже была
15 сен 08, 14:46    [6185747]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
commit;
Member

Откуда: SQL92
Сообщений: 47330
IT-Клоп


она пишеццо как трепонема и уже была


а это новая мутация :)
15 сен 08, 14:47    [6185751]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
Rampage
Member

Откуда:
Сообщений: 16195
Блог
Тигуан (скоро пойдут базары про новый фольц)
15 сен 08, 14:48    [6185762]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148427
Тигуан - это ж не русское слово а некий фольц
15 сен 08, 14:50    [6185770]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148427
нада исконо русские слова, например брандохлыст
15 сен 08, 14:51    [6185781]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
Юрий Носов
Member

Откуда: Казань
Сообщений: 26410
"бделлиум" есть?
15 сен 08, 14:53    [6185797]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
Марbr
Member

Откуда:
Сообщений: 123
энкодер
15 сен 08, 14:54    [6185807]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
Марbr
Member

Откуда:
Сообщений: 123
варистор, варикап :)
15 сен 08, 14:56    [6185815]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
JustPT001
Member [заблокирован]

Откуда: Трепландия
Сообщений: 21544
шарамыжник

------------
Ein Teil von jener Kraft....
15 сен 08, 14:59    [6185842]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
Марbr
Member

Откуда:
Сообщений: 123
говнястик
15 сен 08, 15:00    [6185847]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
dmidek
Member

Откуда: Киев - Дортмунд
Сообщений: 92032
JustPT001
шарамыжник

------------
Ein Teil von jener Kraft....


А шаромыжник то есть !
15 сен 08, 15:00    [6185849]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148427
сардинелла
15 сен 08, 15:00    [6185850]     Ответить | Цитировать Сообщить модератору
Топик располагается на нескольких страницах: [1] 2 3   вперед  Ctrl      все
Все форумы / Архив ПТ Ответить