Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Архив ПТ Новый топик    Ответить
Топик располагается на нескольких страницах: Ctrl  назад   1 [2] 3   вперед  Ctrl      все
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148520
а вот слабо найти слово из лексикона IT?
15 сен 08, 15:00    [6185857]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
nn1000
Member

Откуда: The dark side of the moon
Сообщений: 21217
идиоты
Процедура УдалитьДвиженияРегистратора(ДокументОбъект, Отказ, СтруктураВидовУчета = Неопределено, ОчищатьРегистры = Истина) Экспорт
	
	МассивОбрабатываемыхСтрокТаблицыДвижений = Новый Массив();
	
	РегистрыКБезусловномуУдалению = ОпределитьСписокРегистровСБезусловнымУдалениемДвижений(ДокументОбъект.Ссылка);
	
	// получение списка регистров, по которым существуют движения
	ТаблицаДвижений = ПолныеПрава.ОпределитьНаличиеДвиженийПоРегистратору(ДокументОбъект.Ссылка);
	
	Если ОчищатьРегистры Тогда
		ТаблицаДвижений.Колонки.Добавить("НаборЗаписей");
		ТаблицаДвижений.Колонки.Добавить("БезусловноеУдаление", Новый ОписаниеТипов("Булево"));
			
		Для Каждого СтрокаДвижения ИЗ ТаблицаДвижений Цикл
			// имя регистра передается как значение, полученное с помощью
			// функции ПолноеИмя() метаданных регистра
			ПозицияТочки = Найти(СтрокаДвижения.Имя, ".");
			ТипРегистра = Лев(СтрокаДвижения.Имя, ПозицияТочки - 1);
			ИмяРегистра = СокрП(Сред(СтрокаДвижения.Имя, ПозицияТочки + 1));
			
			// необходимо очищать только те регистры, которые относятся к видам учета по которым перепроводиться документ
			Если (НЕ СтруктураВидовУчета = Неопределено) И (ТипЗНЧ(СтруктураВидовУчета) = Тип("Структура")) Тогда
				Если НЕ ОпределитьПринадлежностьРегистраКВидамУчета(ИмяРегистра, СтруктураВидовУчета) Тогда
					Продолжить;
				КонецЕсли;
			КонецЕсли;	
			
			МассивОбрабатываемыхСтрокТаблицыДвижений.Добавить(СтрокаДвижения);
			
			Если (НЕ РегистрыКБезусловномуУдалению = Неопределено) И РегистрыКБезусловномуУдалению.Свойство(ИмяРегистра) Тогда
				СтрокаДвижения.БезусловноеУдаление = Истина;
				Набор = ИмяРегистра;
			Иначе		
				
				ЕСли ТипРегистра = "РегистрНакопления" Тогда
					МетаданныеНабора = Метаданные.РегистрыНакопления[ИмяРегистра];
					Набор = РегистрыНакопления[ИмяРегистра].СоздатьНаборЗаписей();
						
				ИначеЕсли ТипРегистра = "РегистрБухгалтерии" Тогда
					МетаданныеНабора = Метаданные.РегистрыБухгалтерии[ИмяРегистра];
					Набор = РегистрыБухгалтерии[ИмяРегистра].СоздатьНаборЗаписей();
						
				ИначеЕсли ТипРегистра = "РегистрСведений" Тогда
					МетаданныеНабора = Метаданные.РегистрыСведений[ИмяРегистра];
					Набор = РегистрыСведений[ИмяРегистра].СоздатьНаборЗаписей();
						
				ИначеЕсли ТипРегистра = "РегистрРасчета" Тогда
					МетаданныеНабора = Метаданные.РегистрыРасчета[ИмяРегистра];
					Набор = РегистрыРасчета[ИмяРегистра].СоздатьНаборЗаписей();
						
				КонецЕсли;
					
				Если НЕ ПравоДоступа("Изменение", МетаданныеНабора) Тогда
					// отсутствуют права на всю таблицу регистра
					СообщитьОбОшибке("Нарушение прав доступа", Отказ, СтрокаДвижения.Имя);
					Возврат;
				КонецЕсли;
					
				Набор.Отбор.Регистратор.Установить(ДокументОбъект.Ссылка);			
			КонецЕсли;	
			// набор не записывается сразу, чтобы не откатывать транзакцию, если впоследствии
			// выяснится, что на один из регистров не хватает прав.		
			СтрокаДвижения.НаборЗаписей = Набор;		
			
		КонецЦикла;	
			
		Для Каждого СтрокаДвижения ИЗ МассивОбрабатываемыхСтрокТаблицыДвижений Цикл		
			Если СтрокаДвижения.БезусловноеУдаление Тогда
				ПолныеПрава.ЗаписатьНаборЗаписейНаСервере(СтрокаДвижения.НаборЗаписей, ДокументОбъект.Ссылка);
			Иначе		
				Попытка
					СтрокаДвижения.НаборЗаписей.Записать();
				Исключение
					// возможно «сработал» RLS или механизм даты запрета изменения
					СообщитьОбОшибке(ОписаниеОшибки(), Отказ, СтрокаДвижения.Имя);
					ВызватьИсключение "Операция не выполнена";
				КонецПопытки;
			КонецЕсли;	
		КонецЦикла;
			
	Иначе
		Для Каждого СтрокаДвижения ИЗ ТаблицаДвижений Цикл
			// имя регистра передается как значение, полученное с помощью
			// функции ПолноеИмя() метаданных регистра
			ПозицияТочки = Найти(СтрокаДвижения.Имя, ".");
			ИмяРегистра = СокрП(Сред(СтрокаДвижения.Имя, ПозицияТочки + 1));
			ДокументОбъект.Движения[ИмяРегистра].Очистить();
		КонецЦикла;	
	КонецЕсли;
	
	//Если требуется очищать регистры, то нужно проверять количество записей в наборе перед очисткой
	ОчисткаКоллекцииДвиженийДокумента(ДокументОбъект);
	
	// Удаление записей регистрации из всех последовательностей
	ОбщегоНазначения.УдалитьРегистрациюДокументаВПоследовательностях(ДокументОбъект, Истина);
	
КонецПроцедуры


Торас отжОг! Оверквот - зло???
15 сен 08, 15:00    [6185860]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
JustPT001
Member [заблокирован]

Откуда: Трепландия
Сообщений: 21544
Метаморф

------------
Ein Teil von jener Kraft....
15 сен 08, 15:01    [6185861]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
JustPT001
Member [заблокирован]

Откуда: Трепландия
Сообщений: 21544
Остеогенез

------------
Ein Teil von jener Kraft....
15 сен 08, 15:02    [6185867]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
C#C++
Member [заблокирован]

Откуда: Суровые северные земли
Сообщений: 2636
А вот, например, слово, которое нашлось только в самом большом топике всех времен
15 сен 08, 15:02    [6185874]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
akopium
Member

Откуда: Донецк
Сообщений: 1246
IT-Клоп
а вот слабо найти слово из лексикона IT?

брандмауЗер
15 сен 08, 15:04    [6185887]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148520
C#C++
А вот, например, слово, которое нашлось только в самом большом топике всех времен


подчёркивает... интеллектуальность того топика
15 сен 08, 15:05    [6185899]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
Рыжий Кот
Member

Откуда: Мягкий Диван; [забанен] Рустамом; [разбанен] П02;
Сообщений: 21695
Ятрохимия
15 сен 08, 15:05    [6185901]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148520
IT-Клоп
а вот слабо найти слово из лексикона IT?


транкирование
15 сен 08, 15:06    [6185909]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
sysdate
Member

Откуда: Москва/Севастополь
Сообщений: 12857
идиоты
Процедура УдалитьДвиженияРегистратора(ДокументОбъект, Отказ, СтруктураВидовУчета = Неопределено, ОчищатьРегистры = Истина) Экспорт
	
	МассивОбрабатываемыхСтрокТаблицыДвижений = Новый Массив();
	
	РегистрыКБезусловномуУдалению = ОпределитьСписокРегистровСБезусловнымУдалениемДвижений(ДокументОбъект.Ссылка);
	
	// получение списка регистров, по которым существуют движения
	ТаблицаДвижений = ПолныеПрава.ОпределитьНаличиеДвиженийПоРегистратору(ДокументОбъект.Ссылка);
	
	Если ОчищатьРегистры Тогда
		ТаблицаДвижений.Колонки.Добавить("НаборЗаписей");
		ТаблицаДвижений.Колонки.Добавить("БезусловноеУдаление", Новый ОписаниеТипов("Булево"));
			
		Для Каждого СтрокаДвижения ИЗ ТаблицаДвижений Цикл
			// имя регистра передается как значение, полученное с помощью
			// функции ПолноеИмя() метаданных регистра
			ПозицияТочки = Найти(СтрокаДвижения.Имя, ".");
			ТипРегистра = Лев(СтрокаДвижения.Имя, ПозицияТочки - 1);
			ИмяРегистра = СокрП(Сред(СтрокаДвижения.Имя, ПозицияТочки + 1));
			
			// необходимо очищать только те регистры, которые относятся к видам учета по которым перепроводиться документ
			Если (НЕ СтруктураВидовУчета = Неопределено) И (ТипЗНЧ(СтруктураВидовУчета) = Тип("Структура")) Тогда
				Если НЕ ОпределитьПринадлежностьРегистраКВидамУчета(ИмяРегистра, СтруктураВидовУчета) Тогда
					Продолжить;
				КонецЕсли;
			КонецЕсли;	
			
			МассивОбрабатываемыхСтрокТаблицыДвижений.Добавить(СтрокаДвижения);
			
			Если (НЕ РегистрыКБезусловномуУдалению = Неопределено) И РегистрыКБезусловномуУдалению.Свойство(ИмяРегистра) Тогда
				СтрокаДвижения.БезусловноеУдаление = Истина;
				Набор = ИмяРегистра;
			Иначе		
				
				ЕСли ТипРегистра = "РегистрНакопления" Тогда
					МетаданныеНабора = Метаданные.РегистрыНакопления[ИмяРегистра];
					Набор = РегистрыНакопления[ИмяРегистра].СоздатьНаборЗаписей();
						
				ИначеЕсли ТипРегистра = "РегистрБухгалтерии" Тогда
					МетаданныеНабора = Метаданные.РегистрыБухгалтерии[ИмяРегистра];
					Набор = РегистрыБухгалтерии[ИмяРегистра].СоздатьНаборЗаписей();
						
				ИначеЕсли ТипРегистра = "РегистрСведений" Тогда
					МетаданныеНабора = Метаданные.РегистрыСведений[ИмяРегистра];
					Набор = РегистрыСведений[ИмяРегистра].СоздатьНаборЗаписей();
						
				ИначеЕсли ТипРегистра = "РегистрРасчета" Тогда
					МетаданныеНабора = Метаданные.РегистрыРасчета[ИмяРегистра];
					Набор = РегистрыРасчета[ИмяРегистра].СоздатьНаборЗаписей();
						
				КонецЕсли;
					
				Если НЕ ПравоДоступа("Изменение", МетаданныеНабора) Тогда
					// отсутствуют права на всю таблицу регистра
					СообщитьОбОшибке("Нарушение прав доступа", Отказ, СтрокаДвижения.Имя);
					Возврат;
				КонецЕсли;
					
				Набор.Отбор.Регистратор.Установить(ДокументОбъект.Ссылка);			
			КонецЕсли;	
			// набор не записывается сразу, чтобы не откатывать транзакцию, если впоследствии
			// выяснится, что на один из регистров не хватает прав.		
			СтрокаДвижения.НаборЗаписей = Набор;		
			
		КонецЦикла;	
			
		Для Каждого СтрокаДвижения ИЗ МассивОбрабатываемыхСтрокТаблицыДвижений Цикл		
			Если СтрокаДвижения.БезусловноеУдаление Тогда
				ПолныеПрава.ЗаписатьНаборЗаписейНаСервере(СтрокаДвижения.НаборЗаписей, ДокументОбъект.Ссылка);
			Иначе		
				Попытка
					СтрокаДвижения.НаборЗаписей.Записать();
				Исключение
					// возможно «сработал» RLS или механизм даты запрета изменения
					СообщитьОбОшибке(ОписаниеОшибки(), Отказ, СтрокаДвижения.Имя);
					ВызватьИсключение "Операция не выполнена";
				КонецПопытки;
			КонецЕсли;	
		КонецЦикла;
			
	Иначе
		Для Каждого СтрокаДвижения ИЗ ТаблицаДвижений Цикл
			// имя регистра передается как значение, полученное с помощью
			// функции ПолноеИмя() метаданных регистра
			ПозицияТочки = Найти(СтрокаДвижения.Имя, ".");
			ИмяРегистра = СокрП(Сред(СтрокаДвижения.Имя, ПозицияТочки + 1));
			ДокументОбъект.Движения[ИмяРегистра].Очистить();
		КонецЦикла;	
	КонецЕсли;
	
	//Если требуется очищать регистры, то нужно проверять количество записей в наборе перед очисткой
	ОчисткаКоллекцииДвиженийДокумента(ДокументОбъект);
	
	// Удаление записей регистрации из всех последовательностей
	ОбщегоНазначения.УдалитьРегистрациюДокументаВПоследовательностях(ДокументОбъект, Истина);
	
КонецПроцедуры
это че за хрень?
15 сен 08, 15:07    [6185918]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
eNose
Member

Откуда: с ПТ
Сообщений: 178817
sysdate
это че за хрень?
это такой ЯП
15 сен 08, 15:08    [6185930]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
C#C++
Member [заблокирован]

Откуда: Суровые северные земли
Сообщений: 2636
sysdate
это че за хрень?
Это множество слов, которые можно найти только в этом топике
15 сен 08, 15:09    [6185936]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
sysdate
Member

Откуда: Москва/Севастополь
Сообщений: 12857
eNose
sysdate
это че за хрень?
это такой ЯП
оригинально, первый раз вижу. как догадываюсь, это 1С?
15 сен 08, 15:10    [6185945]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
eNose
Member

Откуда: с ПТ
Сообщений: 178817
sysdate
eNose
sysdate
это че за хрень?
это такой ЯП
оригинально, первый раз вижу. как догадываюсь, это 1С?
смешной язык, да? :)
15 сен 08, 15:12    [6185955]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
RSman
Member

Откуда: Тромавиль
Сообщений: 2733
IT-Клоп
а вот слабо найти слово из лексикона IT?

Разностная машина Чарльза Бэббиджа :)
15 сен 08, 15:12    [6185960]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
MAPA3OT
Member

Откуда: Над трубами, во чреве коих Яуза живет.
Сообщений: 2588
Гетероскедастичность
Конечный биоавтомат Шапиро
15 сен 08, 15:28    [6186095]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
sysdate
Member

Откуда: Москва/Севастополь
Сообщений: 12857
eNose
sysdate
eNose
sysdate
это че за хрень?
это такой ЯП
оригинально, первый раз вижу. как догадываюсь, это 1С?
смешной язык, да? :)
не, бедные одинэснеки
15 сен 08, 16:14    [6186461]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
sysdate
Member

Откуда: Москва/Севастополь
Сообщений: 12857
Интересно - в Украине используется 1С?
Там внутренний язык перевели или нет?
15 сен 08, 16:19    [6186495]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
nn1000
Member

Откуда: The dark side of the moon
Сообщений: 21217
скатология
15 сен 08, 16:21    [6186513]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
dmidek
Member

Откуда: Киев - Дортмунд
Сообщений: 92138
Хоть крестьянин и английский , а все же всего из 5 букв :-)

Йомен
15 сен 08, 16:25    [6186544]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
Deltinka
Member

Откуда: говно-то?
Сообщений: 11209
ихтиология

Картинка с другого сайта.
15 сен 08, 16:27    [6186560]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
C#C++
Member [заблокирован]

Откуда: Суровые северные земли
Сообщений: 2636
тупoсть не найдена!
15 сен 08, 16:33    [6186590]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
MAPA3OT
Member

Откуда: Над трубами, во чреве коих Яуза живет.
Сообщений: 2588
C#C++
тупoсть не найдена!

Ай-ай-ай, не честно
кoмпьютeр
15 сен 08, 16:37    [6186619]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
IT-Клоп
Member

Откуда: censored
Сообщений: 148520
Угу - и прoграммирование

Играть надо честно
15 сен 08, 17:12    [6186861]     Ответить | Цитировать Сообщить модератору
 Re: Игра: поиск слов  [new]
C#C++
Member [заблокирован]

Откуда: Суровые северные земли
Сообщений: 2636
IT-Клоп
Угу - и прoграммирование

Играть надо честно
Кстати, я как-то ради интереса пробовал таким способом строллить какого-нибудь мембера. Не прокатило.
15 сен 08, 17:23    [6186922]     Ответить | Цитировать Сообщить модератору
Топик располагается на нескольких страницах: Ctrl  назад   1 [2] 3   вперед  Ctrl      все
Все форумы / Архив ПТ Ответить