Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / FoxPro, Visual FoxPro Новый топик    Ответить
 Как задать поля (верхнее, нижнее, левое, правое) на листе Excel  [new]
tiim
Member

Откуда:
Сообщений: 4
Господа программисты подскажите пожалуйста, как задать поля (верхнее, нижнее, левое, правое) на листе Excel
6 окт 11, 08:26    [11392358]     Ответить | Цитировать Сообщить модератору
 Re: Как задать поля (верхнее, нижнее, левое, правое) на листе Excel  [new]
КонецЦикла
Member

Откуда:
Сообщений: 268
&& параметры листа
WITH loExcel
   	WITH .Sheets(1)                  
    	.Select
       	.Name = "Мой лист"
       	.PageSetup.Orientation = xlLandscape
       	.PageSetup.LeftMargin = 10 
       	.PageSetup.RightMargin = 0
       	.PageSetup.TopMargin = 0
       	.PageSetup.BottomMargin = 0
       	.PageSetup.FooterMargin = 0
       	.PageSetup.HeaderMargin = 0
  	ENDWITH
ENDWITH
6 окт 11, 10:19    [11392866]     Ответить | Цитировать Сообщить модератору
 Re: Как задать поля (верхнее, нижнее, левое, правое) на листе Excel  [new]
tiim
Member

Откуда:
Сообщений: 4
Спасибо, помогло.
6 окт 11, 10:44    [11392991]     Ответить | Цитировать Сообщить модератору
 Re: Как задать поля (верхнее, нижнее, левое, правое) на листе Excel  [new]
tanglir
Member

Откуда:
Сообщений: 20087
КонецЦикла
       	.PageSetup.Orientation = xlLandscape
И что, выделенное работает? У меня, помнится, принимало только явно указанные числа.
6 окт 11, 17:14    [11396667]     Ответить | Цитировать Сообщить модератору
 Re: Как задать поля (верхнее, нижнее, левое, правое) на листе Excel  [new]
Игорь Горбонос
Member

Откуда: Днепропетровск
Сообщений: 4225

> Автор: tanglir
> У меня, помнится, принимало только явно указанные числа.


А ты их
+ Define, define ...
  #Define xlCenterCell  -4108
  #Define xlLeftInCell  -4131 &&(&HFFFFEFDD)
  #Define xlRightInCell -4152 &&(&HFFFFEFC8)
  #Define xlLastCell    11
....

:)

Posted via ActualForum NNTP Server 1.4

6 окт 11, 17:46    [11397005]     Ответить | Цитировать Сообщить модератору
 Re: Как задать поля (верхнее, нижнее, левое, правое) на листе Excel  [new]
AndreTM
Member

Откуда: Где-то в вологодских лесах...
Сообщений: 6764
Ну и чтобы ТС не искал:
#Define xlLandscape  2  &&(&H00000002)
6 окт 11, 22:39    [11398391]     Ответить | Цитировать Сообщить модератору
 Re: Как задать поля (верхнее, нижнее, левое, правое) на листе Excel  [new]
КонецЦикла
Member

Откуда:
Сообщений: 268
tanglir
КонецЦикла
       	.PageSetup.Orientation = xlLandscape
И что, выделенное работает? У меня, помнится, принимало только явно указанные числа.


для этого есть директива #define, тогда все будет работать....
7 окт 11, 09:27    [11399456]     Ответить | Цитировать Сообщить модератору
Все форумы / FoxPro, Visual FoxPro Ответить
 
Разработка веб приложений с помощью Visual Studio 2010   29 000 руб.
Java сквозной курс от а до я. от java программирования до разработки java ee 7 web и
ejb приложений с использованием баз данных (на примере mysql)
  57 000 руб.
Создание запросов в SQL Server 2012   29 500 руб.
Администрирование баз данных Microsoft SQL Server   29 500 руб.
Основы web-программирования. HTML, CSS, PHP   26 990 руб.