Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Oracle Новый топик    Ответить
 Вопрос по версиям ORACLE  [new]
Сергей из Самары
Member

Откуда:
Сообщений: 224
Помогите пожалуйста.
Подскажите, кто-нибудь сталкивался с ситуацией, когда запросы и скрипты, разработанные для старых версий oracle, переставали работать не новых версиях? И если можно, примеры, если ситуация возникала. Очень важно!
Заранее спасибо.
15 окт 13, 10:23    [14971095]     Ответить | Цитировать Сообщить модератору
 Re: Вопрос по версиям ORACLE  [new]
Ramin Hashimzade
Member

Откуда: Азербайджан, Баку
Сообщений: 9979
Блог
Сергей из Самары
Помогите пожалуйста.
Подскажите, кто-нибудь сталкивался с ситуацией, когда запросы и скрипты, разработанные для старых версий oracle, переставали работать не новых версиях? И если можно, примеры, если ситуация возникала. Очень важно!
Заранее спасибо.

А что, у тя такая проблема есть?
15 окт 13, 10:30    [14971127]     Ответить | Цитировать Сообщить модератору
 Re: Вопрос по версиям ORACLE  [new]
andreiz
Member

Откуда:
Сообщений: 28
Сергей из Самары,
я так понимаю нужно предоставить начальству возможные риски предстоящего upgrade.
тогда так: указываем текущую версию и будущую, заодно и ОС; читаем release notes будущей версии; ну и люди тут смогут поделиться конкретным опытом.
всего.
15 окт 13, 10:39    [14971173]     Ответить | Цитировать Сообщить модератору
 Re: Вопрос по версиям ORACLE  [new]
Сергей из Самары
Member

Откуда:
Сообщений: 224
Проблемы есть у разработчиков, которые заявили, что не могут представить программу на оркле, поскольку у них возникли проблемы несовместимости их кода, написанного для старых версий, с новыми версиями, на которых они не работают. В результате нам пытаются дать продукт на другой системе.

Я очень сильно усомнился в этом, но все же решил уточнить, действительно ли такое есть.
15 окт 13, 11:58    [14971770]     Ответить | Цитировать Сообщить модератору
 Re: Вопрос по версиям ORACLE  [new]
orawish
Member

Откуда: Гадюкино-2 (City)
Сообщений: 15487
Сергей из Самары,

движение от старых версий сервера к новым гораздо проще проходит, чем в обратную сторону, но проблемы могут быть в любом случае, ибо каждый сервер реализован так, как реализован (+ пропатчен еще, как пропатчен и настроен, как настроен).
15 окт 13, 12:39    [14972186]     Ответить | Цитировать Сообщить модератору
 Re: Вопрос по версиям ORACLE  [new]
BTM
Member

Откуда:
Сообщений: 139
Бывает такое.
Много систем мигрировали с 9i на 11g, например. Грабли были связаны только с работой конечного приложения с обновленным ODBC драйвером на клиенте или (если коннект прямой) с работой конечного приложения с обновленным Oracle Client.
15 окт 13, 12:46    [14972257]     Ответить | Цитировать Сообщить модератору
 Re: Вопрос по версиям ORACLE  [new]
Вася. Стиляга из Москвы
Guest
Попроси пяток самых гарячих несовместимостей и расскажи тут.

Одну кстати я уже заметил:
Сергей из Самары
...пытаются дать продукт на другой системе...
15 окт 13, 12:47    [14972268]     Ответить | Цитировать Сообщить модератору
 Re: Вопрос по версиям ORACLE  [new]
-=APS=-
Member

Откуда: Киев
Сообщений: 737
Присоединюсь к мнению BTM на предмет того, что, если "разнообразного и разномастного" софта много, то связка прикладной софт <-> Oracle Client во всем разнообразии сочетаний может реально стать головной болью. :) А вот, чтобы массово запросы/скрипты переставали работать - это вряд ли.

По поводу перехода 9i -> 11g сходу вспоминаются такие "всплывшие" моменты:
- ora-29471 access denied при работе с dbms_sql, блокирующий работу (проблема связана с неаккуратно написанным кодом, который на 9-ке был не столь "страшен")
- создание ACL (при работе UTL_HTTP)
- group by без явного order by + использование ожидаемой упорядоченной выборки (пожалуй, ситуация частично подходит под ваш вопрос насчет "переставали работать"; опять же подчеркну - это проблема неаккуратно написанного кода)
15 окт 13, 14:04    [14972965]     Ответить | Цитировать Сообщить модератору
 Re: Вопрос по версиям ORACLE  [new]
Vint
Member

Откуда: Москва
Сообщений: 4564
-=APS=-,
в первом релизе 10ки были некоторые фичи которые были отключены во втором релизе. и до сих пор не реализованы.... и есть пара больших систем которые как раз из за этих ФИЧ не могут перекочевать) так что не всё так просто...
15 окт 13, 14:29    [14973221]     Ответить | Цитировать Сообщить модератору
Все форумы / Oracle Ответить