Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft SQL Server Новый топик    Ответить
 Не могу завести (локального) пользователя  [new]
Dr.Hofmann
Member

Откуда:
Сообщений: 264
Всем привет!
Собственно сабж.
Что делаю захожу в Management Studio - Безопасность - Имена входа - Создать имя входа.
Проверку пользователя делаю sql.
Роли: Public , Sysadmin
_______________________

Дальше попытка залогиниться:
Проверка подлинности выбираю sql:
После ввода логина и пароля:

автор
Подключение к серверу успешно установлено, но затем произошла ошибка при входе. (provider: Shared Memory Provider, error: 0 - С обоих концов канала отсутствуют процессы.) (.Net SqlClient Data Provider


автор
------------------------------
Имя сервера: WIN-B5C73718HTK\SQLEXPRESS
Номер ошибки: 233
Серьезность: 20
Состояние: 0


Далее перехожу по ссылке которая фигурирует в описании ошибки:

http://www.microsoft.com/products/ee/transform.aspx?ProdName=Microsoft SQL Server&EvtSrc=MSSQLServer&EvtID=233

там рекомендации:
автор
User Action
Use the SQL Server Surface Area Configuration tool to allow SQL Server to accept remote connections. For more information about the SQL Server Surface Area Configuration Tool, see Surface Area Configuration for Services and Connections


Что не так в натройках на скрине ниже ? Что нужно поправить?

Картинка с другого сайта.
15 май 14, 23:29    [16024325]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
o-o
Guest
Dr.Hofmann,
показываю картинку, где сделано то, что по ссылке просят.
но я никак не пойму: вы удаленно подключаетесь или локально?
раз под виндовой учеткой успешно на сервер заходите, в случае, если удаленно, то и так все разрешено,
а если локально, то и не поможет разрешение удаленных соединений.
может, у вас несколько инстансов и вы не к тому подключаетесь?
вообще номер ошибки не помню, а такой текст вылазит, когда запускаешь запрос в студии,
а при этом соединение уже разорвано. вот тогда и пишет No process is on the other end of the pipe.

К сообщению приложен файл. Размер - 50Kb
16 май 14, 01:33    [16024625]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
Dr.Hofmann
Member

Откуда:
Сообщений: 264
o-o,
автор
Dr.Hofmann,
показываю картинку, где сделано то, что по ссылке просят.
но я никак не пойму: вы удаленно подключаетесь или локально?
раз под виндовой учеткой успешно на сервер заходите, в случае, если удаленно, то и так все разрешено,
а если локально, то и не поможет разрешение удаленных соединений.
может, у вас несколько инстансов и вы не к тому подключаетесь?
вообще номер ошибки не помню, а такой текст вылазит, когда запускаешь запрос в студии,
а при этом соединение уже разорвано. вот тогда и пишет No process is on the other end of the pipe.


автор
но я никак не пойму: вы удаленно подключаетесь или локально?

Локально - только под другим пользователем не под виндовым админом.
автор
может, у вас несколько инстансов и вы не к тому подключаетесь?

модет у меня вообще инстанс не забкщен - тогда наверное я бы не смог вообще авторизоваться ни под одним пользователем.

автор
No process is on the other end of the pipe.

Чета не помню такого
16 май 14, 08:39    [16024935]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
Dr.Hofmann
Member

Откуда:
Сообщений: 264
Да забыл, нужен ли Surface Area Configuration 2005? - для MsSql 2012 подойдет или 2012 есть? или тольлко через Management Studio?
16 май 14, 08:42    [16024944]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
o-o
Guest
Dr.Hofmann
автор
No process is on the other end of the pipe.

Чета не помню такого


говорю, вот эта самая ошибка 233, на инглише вот так выглядит:
Msg 233, Level 20, State 0, Line 0
A transport-level error has occurred when sending the request to the server. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.)

у меня сервера на своем родном пишут, нам так приятнее :)

только вот первая часть ошибки у нас не сходится:
в моей, спровоцированнной остановкой сервера, пишут A transport-level error has occurred when sending the request to the server.
а в вашей-то "A connection was successfully established with the server, but then an error occurred during the login process",
значит, сервер был запущен

Surface Area Configuration был в 2005 и с ним же в лету канул,
у вас что, 2012?

еще раз, плиз, поясните:
вот под виндовым админом зашли,
при этом в соседней сессии заходите под -ом и выдается та ошибка?
при этом если еще одну сессию под админом открыть, то все ок?
или было разнесено по времени и сервис мог просто остановиться
на момент второй попытки?

в errorlog-е сервера что-то интересное пишут?
прикрепите его сюда вложением
(примерный путь: C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG )
16 май 14, 10:52    [16025737]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
invm
Member

Откуда: Москва
Сообщений: 9836
Включите SQL-аутентификацию
16 май 14, 11:00    [16025793]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
o-o
Guest
invm,
a разве при Win only не вывалится 18456 на попытку соединения под SQL Server login-ом?
16 май 14, 12:09    [16026387]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
invm
Member

Откуда: Москва
Сообщений: 9836
o-o
invm,
a разве при Win only не вывалится 18456 на попытку соединения под SQL Server login-ом?
Да, невнимательно прочитал сообщение об ошибке и был неправ.

Dr.Hofmann,
Данная ошибка возникает, когда превышается лимит подключений к серверу. Что вернет
exec sp_configure 'user connections';
?
16 май 14, 13:18    [16026990]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
Dr.Hofmann
Member

Откуда:
Сообщений: 264
o-o
invm,
Что вернет
exec sp_configure 'user connections';
?

автор
Сообщение 15123, уровень 16, состояние 1, процедура sp_configure, строка 62
Параметр конфигурации "user connections" не существует, либо это расширенный параметр.


автор
Surface Area Configuration был в 2005 и с ним же в лету канул,
у вас что, 2012?

Да

автор
при этом если еще одну сессию под админом открыть, то все ок?

Дополнительная сессия открывается

автор
Включите SQL-аутентификацию

Включил.
Появилась новая ошибка:
автор
Имя сервера: WIN-B5C73718HTK\SQLEXPRESS
Номер ошибки: 18456
Серьезность: 14
Состояние: 1
Номер строки: 65536

В описании говориться о сложности пароля - я сделал сложнее с верхним регистром цифрами и точкой результата - нет!

автор
в errorlog-е сервера что-то интересное пишут?
прикрепите его сюда вложением
(примерный путь: C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG )

прикрепил.

К сообщению приложен файл (Log.zip - 102Kb) cкачать
17 май 14, 00:18    [16030092]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
serpentariy
Member

Откуда:
Сообщений: 266
Dr.Hofmann,
А вы это сделали?
А то у вас в Errorlog указано: "Authentication mode is WINDOWS-ONLY."
17 май 14, 01:20    [16030253]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
Dr.Hofmann
Member

Откуда:
Сообщений: 264
serpentariy,

автор
Dr.Hofmann,
А вы это сделали?
А то у вас в Errorlog указано: "Authentication mode is WINDOWS-ONLY."

Да - видимо не сохранилось - сейчас поправил - ошибки ушли - смог залогиниться - создать базу и таблицы.
Всем спасибо, комрады!!!
17 май 14, 01:55    [16030316]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
o-o
Guest
а по поводу первой ошибки, видимо, тут:
2014-05-15 00:25:41.40 spid8s Warning ******************
2014-05-15 00:25:41.40 spid8s SQL Server started in single-user mode. This an informational message only. No user action is required.
17 май 14, 02:05    [16030332]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
o-o
Guest
нет. у меня так и не получилось воспроизвести "A connection was successfully established with the server, but then an error occurred during the login process"
даже если стартует в singe user, на вторую сессию выдает другую ошибку:
Login failed for user.... Reason: Server is in single user mode. Only one administrator can connect at this time. [CLIENT: <local machine>]

слушайте, а покажите правда
exec sp_configure 'user connections';

сперва вот такое запустите:
exec sp_configure 'show advanced option', '1';
reconfigure; 
17 май 14, 02:20    [16030349]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
o-o
Guest
ура, получилось.
именно что ограничить user connections.
сразу вылетит нужная ошибка.

я одно не пойму: если она у ТС была, то должна была в лог попасть:
Error: 17809, Severity: 20, State: 3.
Could not connect because the maximum number of '2' user connections has already been reached.
а ее нету ни в одном из логов.
+ логи у него все: тот с сингл юзер -- это, поди, первый запуск после установки.
мистика, короче...

К сообщению приложен файл. Размер - 12Kb
17 май 14, 02:44    [16030370]     Ответить | Цитировать Сообщить модератору
 Re: Не могу завести (локального) пользователя  [new]
Dr.Hofmann
Member

Откуда:
Сообщений: 264
o-o,

Картинка с другого сайта.
17 май 14, 02:49    [16030376]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft SQL Server Ответить