Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft SQL Server Новый топик    Ответить
 DBArtisan vs #t  [new]
SHKoder
Member

Откуда: Moscow city
Сообщений: 616
на нескольких версих замечен глюк, может я как-то не так подключаесь к серверу или где-то косяк в галке

в общем не понятно как лечить косяк с временными таблицами
все делаю в рамках одной и той же сессии
create table #t (a int)

insert into #t values (0)
insert into #t values (1)
insert into #t values (2)

создал таблицу, наполнил ее
после этого маркером выделаю фрагмент скрипта
select * from #t 

и получаю
Execution Invalid object name '#t'.

при том, что если весь кусок кода выполняю в одном пакете, то все окей, а вот если разными, то такая вот петрушка.
замечено в версиях сабжа 8.6.2 и 9.1.1
между тем, в версии 8.1.2 с этим все в порядке.

просто у 8.1.2 своих проблем предостаточно, а у 9.1.1 их вроде меньше, но других полно.
в 8.6.2 еще тот сборник багов и глюков.

тем не менее, прога очень хорошая, из-за возможности работать в одном окне на гетерогенных БД.

если проблема в какой-то галочке при подключении к сиквелу, буду рад познать ее местонахождение.

в диктанте три-четыре варнинга, но в общем компилируется
23 май 14, 14:04    [16061406]     Ответить | Цитировать Сообщить модератору
 Re: DBArtisan vs #t  [new]
Glory
Member

Откуда:
Сообщений: 104751
SHKoder
после этого маркером выделаю фрагмент скрипта
select * from #t 


и получаю
Execution Invalid object name '#t'.

А этот фрагмент выполняется в том же коннекте ? Это видно в Профайлере ?
23 май 14, 14:27    [16061576]     Ответить | Цитировать Сообщить модератору
 Re: DBArtisan vs #t  [new]
SHKoder
Member

Откуда: Moscow city
Сообщений: 616
да, все в рамках одной сессии, в одном окне, закладке

в общем проблему решил
дурацкий автокоммит


alpmoon
Expert Comment
alpmoon 2010-02-03 at 14:29:27ID: 26479885

You can change DBArtisan's behavior by using options. Options is under File on the top menu bar. Click it and then collapse ISQL and click Sybase on options window. You will see "Auto-commit changes". I guess it is 'on' now, which means every time you execute a statement it is commited automatically. Just make it 'off'


тема закрыта, но на всяк случай, если кому пригодится
23 май 14, 14:37    [16061659]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft SQL Server Ответить