Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft SQL Server Новый топик    Ответить
 Не получается остановить полнотекстовое индексирование  [new]
Anics
Member

Откуда:
Сообщений: 6
Здравствуйте.
Столкнулся с неразрешимой ситуацией.
Полнотекстовое индексирование продолжается более суток,
причем процесс остановился на "Starting", а не "Processing normally"

Пытаюсь остановить командой

USE MyDB;
GO
EXEC sp_fulltext_catalog 'MyDB_fulltext', 'stop';
GO

в результате команда выполняется бесконечно, блокируется системным процессом,
который невозможно KILL.

Было испробовано.
- перезагрузка SQL Server;
- перезагрузка компьютера;

Все бесполезно.

Служба полнотекстового поиска уже остановлена,
select * from sysprocesses показывает блокирующий процесс
cmd = FT CRAWL
hostname и hostprocess - пусто!

Как остановить полнотекстовое индексирование?
27 июн 15, 08:02    [17822937]     Ответить | Цитировать Сообщить модератору
 Re: Не получается остановить полнотекстовое индексирование  [new]
Anics
Member

Откуда:
Сообщений: 6
Здравствуйте.

Полнотекстовое индексирование завершилось успешно самостоятельно.
Выполнялось почти 3 суток.
28 июн 15, 11:06    [17824978]     Ответить | Цитировать Сообщить модератору
 Re: Не получается остановить полнотекстовое индексирование  [new]
Winnipuh
Member [заблокирован]

Откуда: Київ
Сообщений: 10428
Anics
Здравствуйте.

Полнотекстовое индексирование завершилось успешно самостоятельно.
Выполнялось почти 3 суток.


а зачем останавливать? 3 суток - значит
1. у вас каталог офигенный
2. индексируемые таблицы офигенные
3. 1+2
4. посмотрите на диски, где размещена база
5. темпдб
29 июн 15, 12:31    [17827697]     Ответить | Цитировать Сообщить модератору
 Re: Не получается остановить полнотекстовое индексирование  [new]
Anics
Member

Откуда:
Сообщений: 6
Здравствуйте.

Решение найдено.
Может пригодится кому-нибудь.

То, что полнотекстовое индексирование выполняется очень долго,
на это даже специалисты Microsoft сказали, что это фича именно SQL 2012,
на SQL 2008 R2 такого не было.

Вот решение:

ALTER DATABASE [dbname] SET SINGLE_USER
ALTER FULLTEXT INDEX ON [tablename] DISABLE

Других вариантов нет. Остановить полнотекстовое индексирование иначе нельзя.
Не поможет ни перезагрузка SQL Server, ни перезагрузка компьютера, ни перевод с одной ноды кластера на другую.
27 сен 15, 13:12    [18200839]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft SQL Server Ответить