Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Oracle Новый топик    Ответить
 Перестал работать EM Express первого экземпляра OraDB12c1 после того, как поставил второй  [new]
GrayMagellan
Member

Откуда:
Сообщений: 188
Есть у меня рабочий компьютер. На нем стоит Windows 7 с мощным процессором и большим количеством ОЗУ. Поставил как-то себе на компьютер Oracle Database 12c1 в D:\Oracle\App\GrayMagellan\Product\12.1.0\DBHome_1_64. Все работало нормально до тех пор, пока не решил я поставить себе второй экземпляр той же базы, но в другое место (D:\Oracle\App\GrayMagellan\Product\12.1.0\DBHome_2_64). И все бы хорошо, но после развертывания нового движка СУБД перестал работать EM Expreess первого движка!!! На порту 5501 второй EM Express сидит и работает, а первого, который раньше сидел на 5500, и след простыл! Помогите плиз.
9 авг 16, 16:38    [19520983]     Ответить | Цитировать Сообщить модератору
 Re: Перестал работать EM Express первого экземпляра OraDB12c1 после того, как поставил второй  [new]
UDW
Member

Откуда: Самара
Сообщений: 1096
GrayMagellan,

Вот сразу вопрос, а нафига второй экземпляр???
12С создавалась для того, чтобы в одном экземпляре много баз варилось.
9 авг 16, 17:05    [19521121]     Ответить | Цитировать Сообщить модератору
 Re: Перестал работать EM Express первого экземпляра OraDB12c1 после того, как поставил второй  [new]
GrayMagellan
Member

Откуда:
Сообщений: 188
По идее, у меня каждая база сидит в своем хоме:
Первая - в D:\Oracle\App\GrayMagellan\Product\12.1.0\DBHome_1_64
Вторая - в D:\Oracle\App\GrayMagellan\Product\12.1.0\DBHome_2_64

Я полагал, что при таком раскладе и листенеры, и ЕМы будут сидеть в своих каталогах и не пересекаться друг с другом. Установщик второй базы правильно определил, что дефолтные порты 5500 и 1521 уже заняты, и посадил службы второй базы на 5501 и 1522 соответственно. ЕМ второй базы на порту 5501 успешно работает. Почему отвалился ЕМ первой базы на порту 5500? Служба OracleManagementServer_EMGC_OMS1_1 (процесс D:\Oracle\App\EM12C\EM12c\oms\bin\nmesrvc.exe) почему-то не хочет стартовать. При попытке запустить долго думает и висит в статусе "Запуск", а затем говорит "Ошибка запуска" и остается незапущенной.
9 авг 16, 17:05    [19521125]     Ответить | Цитировать Сообщить модератору
 Re: Перестал работать EM Express первого экземпляра OraDB12c1 после того, как поставил второй  [new]
GrayMagellan
Member

Откуда:
Сообщений: 188
UDW
GrayMagellan,

Вот сразу вопрос, а нафига второй экземпляр???
12С создавалась для того, чтобы в одном экземпляре много баз варилось.


Первая ставилась для работы исключительно в простом режиме. А вторая - исключительно в контейнерном для тестирования опции MultiTenant. Поэтому и хотелось, чтобы они максимально были автономны друг от друга.
9 авг 16, 17:07    [19521140]     Ответить | Цитировать Сообщить модератору
 Re: Перестал работать EM Express первого экземпляра OraDB12c1 после того, как поставил второй  [new]
Вячеслав Любомудров
Member

Откуда: Владивосток
Сообщений: 18486
GrayMagellan
Служба OracleManagementServer_EMGC_OMS1_1 (процесс D:\Oracle\App\EM12C\EM12c\oms\bin\nmesrvc.exe) почему-то не хочет стартовать. При попытке запустить долго думает и висит в статусе "Запуск", а затем говорит "Ошибка запуска" и остается незапущенной.
Ну и?
Ты заглянул в логи?
9 авг 16, 17:08    [19521153]     Ответить | Цитировать Сообщить модератору
 Re: Перестал работать EM Express первого экземпляра OraDB12c1 после того, как поставил второй  [new]
GrayMagellan
Member

Откуда:
Сообщений: 188
GrayMagellan
UDW
GrayMagellan,

Вот сразу вопрос, а нафига второй экземпляр???
12С создавалась для того, чтобы в одном экземпляре много баз варилось.


Первая ставилась для работы исключительно в простом режиме. А вторая - исключительно в контейнерном для тестирования опции MultiTenant. Поэтому и хотелось, чтобы они максимально были автономны друг от друга.


Да! Еще первая база ставилась для поддержки и тестирования функционала EM 12c Cloud Control и поддерживает его базы. Я бы понял и простил, что отвалился EM CC, но почему отвалился и EM Express первой базы?!
9 авг 16, 17:09    [19521160]     Ответить | Цитировать Сообщить модератору
 Re: Перестал работать EM Express первого экземпляра OraDB12c1 после того, как поставил второй  [new]
GrayMagellan
Member

Откуда:
Сообщений: 188
Вячеслав Любомудров
GrayMagellan
Служба OracleManagementServer_EMGC_OMS1_1 (процесс D:\Oracle\App\EM12C\EM12c\oms\bin\nmesrvc.exe) почему-то не хочет стартовать. При попытке запустить долго думает и висит в статусе "Запуск", а затем говорит "Ошибка запуска" и остается незапущенной.
Ну и?
Ты заглянул в логи?


Знать бы где они лежат... У Оракла логов больше чем звезд на небе.
9 авг 16, 17:10    [19521165]     Ответить | Цитировать Сообщить модератору
 Re: Перестал работать EM Express первого экземпляра OraDB12c1 после того, как поставил второй  [new]
GrayMagellan
Member

Откуда:
Сообщений: 188
Короче, опытным путем было установлено, что проблема не в EM, а в самой базе, которая хранит его информацию. По ходу дела база упала потому, что повредился ее файл SYSTEM01.DBF. Будем лечить... Но это уже совсем другая история.

P.S. Скорее всего неполадка вызвана не установкой второй базы рядом с первой, а стечением обстоятельств. Может быть, звезд?
11 авг 16, 16:25    [19530244]     Ответить | Цитировать Сообщить модератору
Все форумы / Oracle Ответить