Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Delphi Новый топик    Ответить
 PAServer от 10.3 на OpenSUSE  [new]
Janex
Member

Откуда: Латвия
Сообщений: 1039
Привет всем.

Поставил новыи 10.3 и OpenSUSE.
Скопировал туда paserver , запускаю и на тебе ошибка:
Segmentation fault (core dumped)

Думал paserver от 10.3 глючныи - попробовал от 10.2.3 и тож самое :(
Чё ето такое, как побороть ?

WBR
Janex
7 дек 18, 11:11    [21756763]     Ответить | Цитировать Сообщить модератору
 Re: PAServer от 10.3 на OpenSUSE  [new]
wadman
Member

Откуда: Санкт-Петербург
Сообщений: 24602
Janex
Поставил новыи 10.3 и OpenSUSE.
Скопировал туда paserver , запускаю и на тебе ошибка:
Segmentation fault (core dumped)

Когда-то вообще работал на этой ОС?
7 дек 18, 11:18    [21756766]     Ответить | Цитировать Сообщить модератору
 Re: PAServer от 10.3 на OpenSUSE  [new]
Janex
Member

Откуда: Латвия
Сообщений: 1039
wadman,

Нет, до етого на OracleLinux работал.
Там протестировал paserver от 10.3, там работает ...
7 дек 18, 11:37    [21756792]     Ответить | Цитировать Сообщить модератору
 Re: PAServer от 10.3 на OpenSUSE  [new]
Janex
Member

Откуда: Латвия
Сообщений: 1039
Прочитал где то что Embarcadero пока неподдерживает paserver для OpenSUSE, хотя
нашёл статью где описано как его запустить под OpenSUSE, значит у како то работает,
мож изза версии - там кокая то другая била...

Но вот что ешё обнаружил - сделал тестовыи пример под Oracle Linux, работает, запускаю
тот же екзешник под OpenSUSE и тут опять то же:
Segmentation fault (core dumped)
7 дек 18, 13:37    [21757004]     Ответить | Цитировать Сообщить модератору
 Re: PAServer от 10.3 на OpenSUSE  [new]
Janex
Member

Откуда: Латвия
Сообщений: 1039
Проинсталировал свежии open SUSE и опаньки ... работает
и моя апликация и paserver ...
Изза чего ето ето всё неработает в другои инсталяцие?
Мож что то инсталировал и какие то libraries поставились других версии
кем paserver кормится?
Вроде только FPC и Lazarus ставил ...
7 дек 18, 15:45    [21757184]     Ответить | Цитировать Сообщить модератору
 Re: PAServer от 10.3 на OpenSUSE  [new]
Janex
Member

Откуда: Латвия
Сообщений: 1039
paserver перестаёт работать если установить пакет GTK2 (нужен для Lazarus).
Будем копать дальше...
Мож у каго то идеи как ето побороть?
7 дек 18, 19:23    [21757537]     Ответить | Цитировать Сообщить модератору
 Re: PAServer от 10.3 на OpenSUSE  [new]
Siemargl
Member

Откуда: 010100
Сообщений: 5969
Janex,

OEL это redhat, Suse это slackware.

Это немного разные ветки линуха. Конечно, должно работать и там и там, но у кого то лапки.

Пробуй на ветке редхата - центос в 1ю очередь
7 дек 18, 22:55    [21757653]     Ответить | Цитировать Сообщить модератору
Все форумы / Delphi Ответить