Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / PHP, Perl, Python Новый топик    Ответить
 Моя Joomla не права на местном сайте  [new]
siavash82ir
Member

Откуда:
Сообщений: 3
Моя Joomla не права на местном сайте


Здравствуйте друзья
У меня есть сайт, который я скачал для кого-то, и я установил его на локальном компьютере. Я не знаю, что такое JoomlLeauer и что со мной не так!

( ! ) Deprecated: iconv_set_encoding(): Use of iconv.internal_encoding is deprecated in F:\wamp64\www\hadidsaz\public_html\libraries\joomla\string\string.php on line 27
( ! ) Warning: session_start(): Cannot send session cookie - headers already sent by (output started at F:\wamp64\www\hadidsaz\public_html\libraries\joomla\string\string.php:27) in F:\wamp64\www\hadidsaz\public_html\libraries\joomla\session\session.php on line 658


Спасибо, что посоветовали мне, как исправить эту ошибку
Спасибо
23 янв 19, 18:44    [21792591]     Ответить | Цитировать Сообщить модератору
 Re: Моя Joomla не права на местном сайте  [new]
vkle
Member

Откуда: Самара
Сообщений: 14557
Дык в мануале русским по белому написано, что директива iconv.internal_encoding устарела, начиная с PHP 5.6.0 и вместо нее default_charset следует использовать. При необходимости, разумеется.

Возможно, это не единственная проблема несовместимости движка с используемой версией PHP и есть смысл (по ситуации, разумеется) обновить движок или установить на сервер более старую версию PHP.
23 янв 19, 19:11    [21792607]     Ответить | Цитировать Сообщить модератору
 Re: Моя Joomla не права на местном сайте  [new]
siavash82ir
Member

Откуда:
Сообщений: 3
vkle
Дык в мануале русским по белому написано, что директива iconv.internal_encoding устарела, начиная с PHP 5.6.0 и вместо нее default_charset следует использовать. При необходимости, разумеется.

Возможно, это не единственная проблема несовместимости движка с используемой версией PHP и есть смысл (по ситуации, разумеется) обновить движок или установить на сервер более старую версию PHP.



Конечно, я просто изменил версию php, но эта ошибка все еще отображается
24 янв 19, 11:08    [21793047]     Ответить | Цитировать Сообщить модератору
 Re: Моя Joomla не права на местном сайте  [new]
vkle
Member

Откуда: Самара
Сообщений: 14557
Какая версия php сейчас реально используется?
24 янв 19, 14:47    [21793406]     Ответить | Цитировать Сообщить модератору
 Re: Моя Joomla не права на местном сайте  [new]
siavash82ir
Member

Откуда:
Сообщений: 3
vkle
Какая версия php сей'час реально используется'?

Я использую версию 5.4
И из wampserver
24 янв 19, 17:33    [21793682]     Ответить | Цитировать Сообщить модератору
Все форумы / PHP, Perl, Python Ответить