Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Oracle Новый топик    Ответить
Топик располагается на нескольких страницах: [1] 2   вперед  Ctrl      все
 SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321

Здравствуйте, ВСЕ!

SQL Developer 19.1.0.094
Connection Type: Basic
Autentification Type: Default

При попытке соединения имеем:
[fix]An error was encountered performing the requested operation:

ORA-00604: error occurred at recursive SQL level 1
ORA-12705: invalid or unknown NLS parameter value specified
00604. 00000 - "error occurred at recursive SQL level %s"
*Cause: An error occurred while processing a recursive SQL statement
(a statement applying to internal dictionary tables).
*Action: If the situation described in the next error on the stack
can be corrected, do so; otherwise contact Oracle Support.
Vendor code 604[/fix]

Что где подкрутить?

--
Регардсы и прочее

Posted via ActualForum NNTP Server 1.5

4 июн 19, 17:12    [21901726]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Vadim Lejnin
Member

Откуда:
Сообщений: 6793
Мимопроходящий
Здравствуйте, ВСЕ!

SQL Developer 19.1.0.094
Connection Type: Basic
Autentification Type: Default

При попытке соединения имеем:
An error was encountered performing the requested operation:

ORA-00604: error occurred at recursive SQL level 1
ORA-12705: invalid or unknown NLS parameter value specified
00604. 00000 - "error occurred at recursive SQL level %s"
*Cause: An error occurred while processing a recursive SQL statement
(a statement applying to internal dictionary tables).
*Action: If the situation described in the next error on the stack
can be corrected, do so; otherwise contact Oracle Support.
Vendor code 604

Что где подкрутить?

--
Регардсы и прочее


Какая ОС клиента?
Какая база, версия
Что возвращает
echo "select value from nls_database_parameters where parameter='NLS_CHARACTERSET';" | sqlplus /
echo "select value from v\$nls_valid_values where parameter='CHARACTERSET';" | sqlplus /



через sql*plus подключается?
4 июн 19, 17:23    [21901737]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
xtender
Member

Откуда: Мск
Сообщений: 5216
Мимопроходящий,

переменные окружения в порядке?
на никсах:
env | grep -i nls

на винде
set | findstr NLS
и в реестре еще проверить.

Если они в порядке, то проверить логон триггеры
4 июн 19, 17:34    [21901751]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Vadim Lejnin
Member

Откуда:
Сообщений: 6793
xtender
Мимопроходящий,

переменные окружения в порядке?
на никсах:
env | grep -i nls

на винде
set | findstr NLS
и в реестре еще проверить.

Если они в порядке, то проверить логон триггеры


Это java, ojdbc не использует NLS_LANG
4 июн 19, 17:47    [21901770]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Vadim Lejnin
Member

Откуда:
Сообщений: 6793
xtender
Мимопроходящий,

переменные окружения в порядке?
на никсах:
env | grep -i nls

на винде
set | findstr NLS
и в реестре еще проверить.

Если они в порядке, то проверить логон триггеры


Это java, ojdbc не использует NLS_LANG

Перейдите в
<директория где установлен Oracle sql developer>/sqldeveloper/sqldeveloper/bin/
Откройте sqldeveloper.conf с помощью текстового редактора.
Добавьте следующие строки:

AddVMOption -Duser.language=en
AddVMOption -Duser.region=US
AddVMOption -Duser.country=en
4 июн 19, 17:48    [21901774]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321
Vadim Lejnin
Какая ОС клиента?
Win7 x64 и Win XP (x32), без разницы.

Vadim Lejnin
Какая база, версия
Oracle9i Release 9.2.0.8.0 - Production

Vadim Lejnin
через sql*plus подключается?
да.
через MicroClient8i тоже.

Vadim Lejnin
Что возвращает
echo "select value from nls_database_parameters where parameter='NLS_CHARACTERSET';" | sqlplus /
такая команда в терминале не прокатывает, ибо юзер-наме ивалид.
если выполнить селект в sqlplus, то
CL8MSWIN1251
Vadim Lejnin
echo "select value from v\$nls_valid_values where parameter='CHARACTERSET';" | sqlplus /
аналогично, выполняю в sqlplus
+ 258 строк...
VALUE
----------------------------------------------------------------
US7ASCII
WE8DEC
WE8HP
US8PC437
WE8EBCDIC37
WE8EBCDIC500
WE8EBCDIC1140
WE8EBCDIC285
WE8EBCDIC1146
WE8PC850
D7DEC
F7DEC
S7DEC
E7DEC
SF7ASCII
NDK7DEC
I7DEC
NL7DEC
CH7DEC
YUG7ASCII
SF7DEC
TR7DEC
IW7IS960
IN8ISCII
WE8EBCDIC1148
WE8PC858
WE8ISO8859P1
EE8ISO8859P2
SE8ISO8859P3
NEE8ISO8859P4
CL8ISO8859P5
AR8ISO8859P6
EL8ISO8859P7
IW8ISO8859P8
WE8ISO8859P9
NE8ISO8859P10
TH8TISASCII
TH8TISEBCDIC
BN8BSCII
VN8VN3
VN8MSWIN1258
WE8ISO8859P15
BLT8ISO8859P13
CEL8ISO8859P14
CL8ISOIR111
WE8NEXTSTEP
CL8KOI8U
AR8ASMO708PLUS
AR8EBCDICX
AR8XBASIC
EL8DEC
TR8DEC
WE8EBCDIC37C
WE8EBCDIC500C
IW8EBCDIC424
TR8EBCDIC1026
WE8EBCDIC871
WE8EBCDIC284
WE8EBCDIC1047
WE8EBCDIC1140C
WE8EBCDIC1145
WE8EBCDIC1148C
WE8EBCDIC1047E
WE8EBCDIC924
EEC8EUROASCI
EEC8EUROPA3
LA8PASSPORT
BG8PC437S
EE8PC852
RU8PC866
RU8BESTA
IW8PC1507
RU8PC855
TR8PC857
CL8MACCYRILLIC
CL8MACCYRILLICS
WE8PC860
IS8PC861
EE8MACCES
EE8MACCROATIANS
TR8MACTURKISHS
IS8MACICELANDICS
EL8MACGREEKS
IW8MACHEBREWS
EE8MSWIN1250
CL8MSWIN1251
ET8MSWIN923
BG8MSWIN
EL8MSWIN1253
IW8MSWIN1255
LT8MSWIN921
TR8MSWIN1254
WE8MSWIN1252
BLT8MSWIN1257
D8EBCDIC273
I8EBCDIC280
DK8EBCDIC277
S8EBCDIC278
EE8EBCDIC870
CL8EBCDIC1025
F8EBCDIC297
IW8EBCDIC1086
CL8EBCDIC1025X
D8EBCDIC1141
N8PC865
BLT8CP921
LV8PC1117
LV8PC8LR
BLT8EBCDIC1112
LV8RST104090
CL8KOI8R
BLT8PC775
DK8EBCDIC1142
S8EBCDIC1143
I8EBCDIC1144
F7SIEMENS9780X
E7SIEMENS9780X
S7SIEMENS9780X
DK7SIEMENS9780X
N7SIEMENS9780X
I7SIEMENS9780X
D7SIEMENS9780X
F8EBCDIC1147
WE8GCOS7
EL8GCOS7
US8BS2000
D8BS2000
F8BS2000
E8BS2000
DK8BS2000
S8BS2000
WE8BS2000E
WE8BS2000
EE8BS2000
CE8BS2000
CL8BS2000
WE8BS2000L5
WE8DG
WE8NCR4970
WE8ROMAN8
EE8MACCE
EE8MACCROATIAN
TR8MACTURKISH
IS8MACICELANDIC
EL8MACGREEK
IW8MACHEBREW
US8ICL
WE8ICL
WE8ISOICLUK
EE8EBCDIC870C
EL8EBCDIC875S
TR8EBCDIC1026S
BLT8EBCDIC1112S
IW8EBCDIC424S
EE8EBCDIC870S
CL8EBCDIC1025S
TH8TISEBCDICS
AR8EBCDIC420S
CL8EBCDIC1025C
CL8EBCDIC1025R
EL8EBCDIC875R
CL8EBCDIC1158
CL8EBCDIC1158R
EL8EBCDIC423R
WE8MACROMAN8
WE8MACROMAN8S
TH8MACTHAI
TH8MACTHAIS
HU8CWI2
EL8PC437S
EL8EBCDIC875
EL8PC737
LT8PC772
LT8PC774
EL8PC869
EL8PC851
CDN8PC863
HU8ABMOD
AR8ASMO8X
AR8NAFITHA711T
AR8SAKHR707T
AR8MUSSAD768T
AR8ADOS710T
AR8ADOS720T
AR8APTEC715T
AR8NAFITHA721T
AR8HPARABIC8T
AR8NAFITHA711
AR8SAKHR707
AR8MUSSAD768
AR8ADOS710
AR8ADOS720
AR8APTEC715
AR8MSWIN1256
AR8MSAWIN
AR8NAFITHA721
AR8SAKHR706
AR8ARABICMAC
AR8ARABICMACS
AR8ARABICMACT
LA8ISO6937
WE8DECTST
JA16VMS
JA16EUC
JA16EUCYEN
JA16SJIS
JA16DBCS
JA16SJISYEN
JA16EBCDIC930
JA16MACSJIS
JA16EUCTILDE
JA16SJISTILDE
KO16KSC5601
KO16DBCS
KO16KSCCS
KO16MSWIN949
ZHS16CGB231280
ZHS16MACCGB231280
ZHS16GBK
ZHS16DBCS
ZHS32GB18030
ZHT32EUC
ZHT32SOPS
ZHT16DBT
ZHT32TRIS
ZHT16DBCS
ZHT16BIG5
ZHT16CCDC
ZHT16MSWIN950
ZHT16HKSCS
AL24UTFFSS
UTF8
UTFE
AL32UTF8
ZHT32EUCTST
WE16DECTST2
WE16DECTST
KO16TSTSET
JA16TSTSET2
JA16TSTSET
US16TSTFIXED
JA16EUCFIXED
JA16SJISFIXED
JA16DBCSFIXED
KO16KSC5601FIXED
KO16DBCSFIXED
ZHS16CGB231280FIXED
ZHS16GBKFIXED
ZHS16DBCSFIXED
ZHT32EUCFIXED
ZHT32TRISFIXED
ZHT16DBCSFIXED
ZHT16BIG5FIXED
AL16UTF16
HZ-GB-2312
ISO2022-KR
ISO2022-CN
ISO2022-JP
4 июн 19, 18:26    [21901808]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321
Vadim Lejnin
Откройте sqldeveloper.conf с помощью текстового редактора.
Добавьте следующие строки:
AddVMOption -Duser.language=en
AddVMOption -Duser.region=US
AddVMOption -Duser.country=en
сделал.
коннект прошел успешно.
дерево метаданных построилось.
но теперь при попытке открыть любой объект из дерева возникает следующее:

An error was encountered performing the requested operation:

ORA-01460: unimplemented or unreasonable conversion requested
01460. 00000 - "unimplemented or unreasonable conversion requested"
*Cause:
*Action:
Vendor code 1460
4 июн 19, 18:37    [21901822]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
andrey_anonymous
Member

Откуда: Москва
Сообщений: 17580
Мимопроходящий
SQL Developer 19.1.0.094


Мимопроходящий
Vadim Lejnin
Какая база, версия
Oracle9i Release 9.2.0.8.0 - Production


Слишком древний оракель для этого клиента.
4 июн 19, 19:03    [21901849]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Vadim Lejnin
Member

Откуда:
Сообщений: 6793
Мимопроходящий,

google
ORA-01460 неосуществленное или необоснованное обращение, запрошенное sqldeveloper



Ваша версия SQL Developer использует драйвер JDBC (12.2.1.0), который говорит на диалекте, который ваша версия базы данных не понимает.

Вы можете попробовать использовать толстое клиентское соединение - там, где вы бы настроили SQL Developer на использование 11.2.0.3 Instant Client, чтобы установить соединение, и это может помочь, но это зависит от того, сколько лет ваша база данных.

Другой вариант - использовать более старую версию SQL Developer, которая поставляется с более старой версией драйвера JDBC.

В идеале вы хотите, чтобы ваши базы данных обновлялись до современных версий. Это окончательное и самое сложное решение.


4 июн 19, 19:04    [21901851]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321

04.06.2019 19:04, Vadim Lejnin пишет:
> Ваша версия SQL Developer использует драйвер JDBC (12.2.1.0), который говорит на диалекте, который ваша версия базы данных не понимает.

такое ощущение что текст переводили Промт'ом...

Posted via ActualForum NNTP Server 1.5

4 июн 19, 19:09    [21901857]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Vadim Lejnin
Member

Откуда:
Сообщений: 6793
Мимопроходящий
04.06.2019 19:04, Vadim Lejnin пишет:
> Ваша версия SQL Developer использует драйвер JDBC (12.2.1.0), который говорит на диалекте, который ваша версия базы данных не понимает.

такое ощущение что текст переводили Промт'ом...


Это фигня, в моем посте главное
google
4 июн 19, 19:35    [21901882]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321

> Это фигня, в моем посте главное
> google

Том заявляет, что разработчики, мягко говоря, не того...
https://asktom.oracle.com/pls/asktom/asktom.search?tag=ora-01460-unimplemented-or-unreasonable-conversion-requested

Posted via ActualForum NNTP Server 1.5

5 июн 19, 11:50    [21902345]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
-2-
Member

Откуда:
Сообщений: 14850
Мимопроходящий,

Для работы с базой 9.2 последний сертифицированный oracle jdbc = 11.2.
Sqldeveloper 19.1 использует oracle jdbc 18.3.
5 июн 19, 12:17    [21902390]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321

05.06.2019 12:17, -2- пишет:
> Для работы с базой 9.2 последний сертифицированный oracle jdbc = 11.2.
> Sqldeveloper 19.1 использует oracle jdbc 18.3.

какая версия SQL Developer использует jdbc 11.2 ?

--
ЗЫ к разработчикам: ужели трудно при коннекте проверять соответствие?

Posted via ActualForum NNTP Server 1.5

5 июн 19, 12:26    [21902401]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
-2-
Member

Откуда:
Сообщений: 14850
Мимопроходящий
ужели трудно при коннекте проверять соответствие?
Это все равно, что каждый раз проверять у жены паспорт - совершеннолетняя ли она для коннекта.
5 июн 19, 13:56    [21902505]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
andrey_anonymous
Member

Откуда: Москва
Сообщений: 17580
-2-
Мимопроходящий
ужели трудно при коннекте проверять соответствие?
Это все равно, что каждый раз проверять у жены паспорт - совершеннолетняя ли она для коннекта.

Жена - не жена, а фаза handshake вполне успешно применяется во многих протоколах.
Заслуженные, опытные протоколы предусматривают также обмен "верительными грамотами" capabilities, что позволяет вычислять общий для "высоких договаривающихся" сторон функционал и, таким образом, успешно договариваться даже с весьма древними пирами.
5 июн 19, 14:06    [21902514]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321

05.06.2019 13:56, -2- пишет:
> Это все равно, что каждый раз проверять у жены паспорт - совершеннолетняя ли она для коннекта.

и тем не менее, версия JDK всё ж таки проверяется на старте.
и в случае несоответствия выдаётся соответствующий ACHTUNG.
(по крайней мере так было в версиях 4.X Sql Developer'а)

Posted via ActualForum NNTP Server 1.5

5 июн 19, 14:21    [21902547]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Vadim Lejnin
Member

Откуда:
Сообщений: 6793
Мимопроходящий
05.06.2019 13:56, -2- пишет:
> Это все равно, что каждый раз проверять у жены паспорт - совершеннолетняя ли она для коннекта.

и тем не менее, версия JDK всё ж таки проверяется на старте.
и в случае несоответствия выдаётся соответствующий ACHTUNG.
(по крайней мере так было в версиях 4.X Sql Developer'а)


Смотрите Oracle Lifetime Support
например: Oracle Lifetime Support: Coverage for Oracle Technology Products

9.2 Закончена поддержка в 2010 году...

К сообщению приложен файл. Размер - 106Kb
5 июн 19, 14:33    [21902563]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321

05.06.2019 14:33, Vadim Lejnin пишет:
> Смотрите Oracle Lifetime Support

при чем здесь ЭТО?
где табличка совместимости версий DBMS и SQL Developer?

Posted via ActualForum NNTP Server 1.5

5 июн 19, 14:51    [21902586]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Vadim Lejnin
Member

Откуда:
Сообщений: 6793
Мимопроходящий
05.06.2019 14:33, Vadim Lejnin пишет:
> Смотрите Oracle Lifetime Support

при чем здесь ЭТО?
где табличка совместимости версий DBMS и SQL Developer?

Это показывает, что Любая поддержка Базы 9i закончилась в 2010 году
и соответственно, если Вы ее используете, то это Ваши проблемы

Вот еще документ:

My Oracle Support Banner
Client / Server Interoperability Support Matrix for Different Oracle Versions (Doc ID 207303.1)

Для oracle sql developer, в качестве jdbc используется ojdbc одной из версий клиента oracle
посмотреть верию ojdbc
можно

java -jar ojdbcX.jar -getversion



Совместимость версий клиента и сервера:

К сообщению приложен файл. Размер - 137Kb
5 июн 19, 14:59    [21902601]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
-2-
Member

Откуда:
Сообщений: 14850
Мимопроходящий
где табличка совместимости версий DBMS и SQL Developer?
В документации по инсталляции sqldeveloper. Только не совместимости, а сертификации.
andrey_anonymous
опытные протоколы предусматривают также обмен "верительными грамотами" capabilities
Протоколы сами по себе, совместимость клиент-сервер несколько сложнее, чтобы уложиться в "верительные грамоты". Универсальность ODBC никоим образом не повод распространять ущербность функционала и производительности на любое взаимодействие с СУБД. И использование ODBC никоим образом не обеспечивает, что sql-ide будет одинаково работать с разными СУБД.
Даже в рамках Oracle Database работоспособность части функций разнится не только от версии, но и от редакции и патчей. Из тысяч подключений в год другая версия СУБД встретится мне только раз. Предупреждение совместимости при коннекте воспримется раздражающим фактором и никак не повлияет на попытку продолжить работать имеющимися средствами, нежели заведомо использовать несколько версий клиента.
5 июн 19, 15:07    [21902616]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321

05.06.2019 14:59, Vadim Lejnin пишет:
> Это показывает, что Любая поддержка Базы 9i закончилась в 2010 году
> и соответственно, если Вы ее используете, то это Ваши проблемы

вы имеете отношение к Oracle?

Posted via ActualForum NNTP Server 1.5

5 июн 19, 15:08    [21902617]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Vadim Lejnin
Member

Откуда:
Сообщений: 6793
Мимопроходящий,

Я там работал, в настоящее время, первая линия поддержки
Сейчас правда уже в основном поддержка не RDBMS, а других продуктов
Официального статуса мои ответы не имеют, так как, в любом случае требуется ссылка на документы MOS. (Даже, если бы я и еще работал в Oracle).

Если будет время, найду официальную ссылку по поводу OFS.
Разумеется, это не касается сторонних продуктов: veriatas/pacemaker и так далее
5 июн 19, 15:14    [21902629]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Мимопроходящий
Member

Откуда: бурятский тундрюк, эсквайр
Сообщений: 30321

05.06.2019 15:07, -2- пишет:
>> Мимопроходящий
>> где табличка совместимости версий DBMS и SQL Developer?
>
> В документации по инсталляции sqldeveloper. Только не совместимости, а сертификации.

https://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/sqldev-install-windows-1969674.html

Windows Installation Notes

There are two downloads available for Windows users.

Windows 64-bit with JDK 8 Included: This archive includes both SQL Developer and an embedded copy of the Java 8 Development Kit (JDK).
Simply extract the zip to a fresh directory and run the sqldeveloper.exe in the top directory. The EXE is configured to run the embedded JDK by default.

Note: the Windows EXE requires a MSVCR100.dll to run. Most computers will already have this file and in the Windows PATH.
However, if the first copy of the file found by the EXE is a 32-bit copy of the DLL, then SQL Developer will fail to start.
You can fix this by copying a 64-bit version of the DLL into the BIN directory or updating your OS PATH such that a 64 bit copy of the DLL is found first.
Windows 32-bit/64-bit: This archive. will work on a 32 or 64 bit Windows OS. The bit level of the JDK you install will determine if it runs as a 32 or 64 bit application.
This download does not include the required Oracle Java JDK. You will need to install it if it's not already on your machine.


If SQL Developer cannot find Java on your machine, it will prompt you for the path for a JDK home.
This only occurs the first time you launch SQL Developer. A valid Java Home on Windows will be similar to
C:\Program Files\Java\jdk1.8.0_181

Posted via ActualForum NNTP Server 1.5

5 июн 19, 15:20    [21902636]     Ответить | Цитировать Сообщить модератору
 Re: SQL Developer (Vendor code 604)  [new]
Vadim Lejnin
Member

Откуда:
Сообщений: 6793
Мимопроходящий,

Посмотрел, если дополнение:
1) OFS - это Oracle plugin для Microsoft Cluster, то есть специфический продукт

В качестве альтернативы, для других ОС, официально существует только Oracle RAC One Node
В целом, это специфическая конфигурация отдельного продукта Oracle Grid Infrastructure
5 июн 19, 15:20    [21902637]     Ответить | Цитировать Сообщить модератору
Топик располагается на нескольких страницах: [1] 2   вперед  Ctrl      все
Все форумы / Oracle Ответить