Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Delphi Новый топик    Ответить
 Подключение модуля в uses  [new]
smoyk
Member

Откуда: Кемерово
Сообщений: 1055
Здравствуйте.
Не могу подключить модуль.
Попал ко мне проект, там в uses подключен SHDocVw_TLB, в объявлении: WebBrowser_V11: TWebBrowser_V1. При открытии проекта ругнулся, что таких компонент не знает.
Открыл Project->"Import Type Library", выбрал "Microsoft Internet Controls", сделал "Create unit", создался файл SHDocVw_TLB в папке Import. Но делфи все равно его не видит.
Подскажите пожалуйста, что еще надо сделать?
Заранее спасибо.
8 июл 19, 11:48    [21922547]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
Tactical Nuclear Penguin
Member

Откуда: холодно тут
Сообщений: 2691
smoyk
Но делфи все равно его не видит.


так и говорит, вслух?
или может пишет чего все-таки?
8 июл 19, 11:52    [21922550]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
wadman
Member

Откуда: Санкт-Петербург
Сообщений: 25569
smoyk
Подскажите пожалуйста, что еще надо сделать?

Собрать и установить?
8 июл 19, 11:59    [21922559]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
smoyk
Member

Откуда: Кемерово
Сообщений: 1055
Tactical Nuclear Penguin
smoyk
Но делфи все равно его не видит.


так и говорит, вслух?
или может пишет чего все-таки?

Пишет. То же самое пишет при повторном открытии проекта, мол не знаю такого компонента и давай его игнор. Кроме того при наведении мышкой на название у других модулей высвечивает имя файла, у этого не высвечивает ничего.
Вобщем файл есть, но делфи его почему то не видит.
8 июл 19, 12:01    [21922564]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
smoyk
Member

Откуда: Кемерово
Сообщений: 1055
wadman
smoyk
Подскажите пожалуйста, что еще надо сделать?

Собрать и установить?

Я был бы признателен, если бы вы сказали, на что нажать...
8 июл 19, 12:03    [21922565]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
smoyk
Member

Откуда: Кемерово
Сообщений: 1055
Сделал Project->"Add to project", и выбрал этот файл. Модуль определился, делфи файл видит. При этом при открытии все равно пишет, что класс TWebBrowser_V1 не найден, хотя он в этом файле есть.
Совсем ничего не понимаю...
8 июл 19, 12:21    [21922581]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
DimaBr
Member

Откуда:
Сообщений: 11128
smoyk
Сделал Project->"Add to project", и выбрал этот файл. Модуль определился, делфи файл видит. При этом при открытии все равно пишет, что класс TWebBrowser_V1 не найден, хотя он в этом файле есть.

Чтобы компонент был виден в дизайнере, нужно компонент устанавливать, а не просто добавлять в проект
8 июл 19, 12:39    [21922600]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
Gerasimenko
Member

Откуда:
Сообщений: 4500
smoyk,

Возможно Вам поможет http://www.delphisources.ru/pages/faq/base/webbrowser_notes.html

Component->Import ActiveX Control...
8 июл 19, 12:41    [21922605]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
smoyk
Member

Откуда: Кемерово
Сообщений: 1055
Gerasimenko
smoyk,

Возможно Вам поможет http://www.delphisources.ru/pages/faq/base/webbrowser_notes.html

Component->Import ActiveX Control...

Прочитал, попробовал установить "Microsoft Internet Controls", пишет "A class named 'TWebBrowser' is already installed.".
9 июл 19, 05:58    [21923165]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
DimaBr
Member

Откуда:
Сообщений: 11128
smoyk
Здравствуйте.
Не могу подключить модуль.
Попал ко мне проект, там в uses подключен SHDocVw_TLB, в объявлении: WebBrowser_V11: TWebBrowser_V1. При открытии проекта ругнулся, что таких компонент не знает.

У вас в проекте используется компонент TWebBrowser_V1 (скорее всего самописный), который был установлен в среду и брошен на форму
9 июл 19, 08:01    [21923185]     Ответить | Цитировать Сообщить модератору
 Re: Подключение модуля в uses  [new]
smoyk
Member

Откуда: Кемерово
Сообщений: 1055
DimaBr,

Понял, спасибо.
9 июл 19, 10:37    [21923256]     Ответить | Цитировать Сообщить модератору
Все форумы / Delphi Ответить