Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Java Новый топик    Ответить
 Vaadin+postgresql 8.4  [new]
else12
Member

Откуда:
Сообщений: 231
Пытаюсь подключить зависимость для постгреса 8.4,но в проекте ваадин дает сделать зависимость для версии не ниже 9.1. Мне бы хотелось по некоторым причинам подключить драйвер для 8.4. (там есть разница в автокоммите, а мне нужно переписывать огромные куски кода со swing) - но не могу этого сделать в pom.xml

Есть ли какая возможность подключить более ранний драйвер? Я где-то читал про помещения jar в библиотеку Tomcat - но, имхо, это какое-то странное решение. Кто-то может подсказать?
8 авг 19, 14:12    [21944713]     Ответить | Цитировать Сообщить модератору
 Re: Vaadin+postgresql 8.4  [new]
Valentin Kolesnikov
Member

Откуда:
Сообщений: 3186
else12
Пытаюсь подключить зависимость для постгреса 8.4,но в проекте ваадин дает сделать зависимость для версии не ниже 9.1. Мне бы хотелось по некоторым причинам подключить драйвер для 8.4. (там есть разница в автокоммите, а мне нужно переписывать огромные куски кода со swing) - но не могу этого сделать в pom.xml

Есть ли какая возможность подключить более ранний драйвер? Я где-то читал про помещения jar в библиотеку Tomcat - но, имхо, это какое-то странное решение. Кто-то может подсказать?


Драйвер для 9.1 должен нормально с 8.4 работать.
8 авг 19, 14:19    [21944731]     Ответить | Цитировать Сообщить модератору
 Re: Vaadin+postgresql 8.4  [new]
else12
Member

Откуда:
Сообщений: 231
Valentin Kolesnikov
else12
Пытаюсь подключить зависимость для постгреса 8.4,но в проекте ваадин дает сделать зависимость для версии не ниже 9.1. Мне бы хотелось по некоторым причинам подключить драйвер для 8.4. (там есть разница в автокоммите, а мне нужно переписывать огромные куски кода со swing) - но не могу этого сделать в pom.xml

Есть ли какая возможность подключить более ранний драйвер? Я где-то читал про помещения jar в библиотеку Tomcat - но, имхо, это какое-то странное решение. Кто-то может подсказать?


Драйвер для 9.1 должен нормально с 8.4 работать.

Он нормально работает, но при записи, емнип, нужно убирать автокоммит. Давно с этим сталкивался, но есть какие-то нюансы. С ваадином только начинаю работать и не все понятно. Там можно какой-то свой репозиторий сделать - если туда бросить 8.4., то мавен сьест?
8 авг 19, 14:23    [21944747]     Ответить | Цитировать Сообщить модератору
 Re: Vaadin+postgresql 8.4  [new]
else12
Member

Откуда:
Сообщений: 231
Тьфу ты... На каком-то левом ресурсе в углу мелким шрифтом нашел, что для версий ниже 9 нужно писать <groupId>postgresql</groupId>, а не org.postgresql...

С документацией у ваадина не во всем порядок...
8 авг 19, 14:41    [21944800]     Ответить | Цитировать Сообщить модератору
 Re: Vaadin+postgresql 8.4  [new]
ferc
Member

Откуда:
Сообщений: 252
else12, а ваадин-то тут причем?
8 авг 19, 14:44    [21944805]     Ответить | Цитировать Сообщить модератору
 Re: Vaadin+postgresql 8.4  [new]
else12
Member

Откуда:
Сообщений: 231
ferc
else12, а ваадин-то тут причем?

Под руку попался...
8 авг 19, 17:49    [21945023]     Ответить | Цитировать Сообщить модератору
Все форумы / Java Ответить