Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft Office Новый топик    Ответить
Топик располагается на нескольких страницах: 1 2      [все]
 Счетесли  [new]
Djois
Member

Откуда: Минск
Сообщений: 25
Добрый день.
Подскажите способ подсчёта в Excel
Например есть таблица с данными
123123
ssffdd
dsfdsf
ssffdd
ffssfs


Нужно подсчитать кол-во ячеек с значением f в столбцах с значением =3
особенность в том, что название столбцов постоянно меняется т.е. вчера был 2 сегодня 3 и т.д.

функция СЧЕТЕСЛИ может подсчитать кол-во ячеек с значением f, но как отобрать f только из столбцов с 3 ?

Сообщение было отредактировано: 4 янв 20, 09:59
4 янв 20, 09:54    [22053326]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Akina
Member

Откуда: Зеленоград, Москва, Россия
Сообщений: 20211
Тут СЧЕТЕСЛИ не справится. Пожалуй, задачка для СУММЕСЛИМН.
4 янв 20, 11:36    [22053344]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Djois
Member

Откуда: Минск
Сообщений: 25
Akina,

да и сумесли не справляется (
4 янв 20, 13:32    [22053368]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
ИВП
Member

Откуда:
Сообщений: 326
Djois,

Для каждого столбика использовать СЧЕТЕСЛИ.
Далее сложить с использованием СУММАЕСЛИ
4 янв 20, 14:12    [22053380]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Djois
Member

Откуда: Минск
Сообщений: 25
ИВП,
Похоже что так и придётся выкручиватся, но столбиков много около 100 - этож какая формула будет)
4 янв 20, 16:04    [22053406]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Akina
Member

Откуда: Зеленоград, Москва, Россия
Сообщений: 20211
Если не влом использовать вспомогательную строку - то всё элементарно. I3=СУММ(A6:F6), есссно.

К сообщению приложен файл. Размер - 7Kb
4 янв 20, 16:19    [22053412]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Djois
Member

Откуда: Минск
Сообщений: 25
Akina
Если не влом использовать вспомогательную строку - то всё элементарно. I3=СУММ(A6:F6), есссно.

совсем не влом!, благодарю, буду сейчас пробовать

зы/ то что доктор прописал!!! Спасибо

Сообщение было отредактировано: 4 янв 20, 16:31
4 янв 20, 16:25    [22053413]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
ИВП
Member

Откуда:
Сообщений: 326
Djois
это ж какая формула будет)

Как раз и имелось в виду два этапа.
А формулы самые простые - как и написал Акина.
4 янв 20, 17:00    [22053418]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Synoptic
Member

Откуда:
Сообщений: 145
Akina
Если не влом использовать вспомогательную строку - то всё элементарно. I3=СУММ(A6:F6), есссно.

Картинка с другого сайта.

Для таких задач проще использовать массивы. Тот же результат, но без дополнительных строк:

K3={=СУММ(($A$2:$F$5=$K$2)*($A$1:$F$1=$K$1))}

К сообщению приложен файл. Размер - 28Kb


Сообщение было отредактировано: 5 янв 20, 06:29
5 янв 20, 06:28    [22053594]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529
Перепробованы ваианты выражения, помещённые в ячейку K3 –
ВСЕ НЕПРАВИЛЬНЫЕ:
={=SUM(($A$2:$F$5=$K$2)*($A$1:$F$1=$K$1))}
=(SUM(($A$2:$F$5=$K$2)*($A$1:$F$1=$K$1)))


К сообщению приложен файл. Размер - 15Kb
5 янв 20, 16:30    [22053764]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Akina
Member

Откуда: Зеленоград, Москва, Россия
Сообщений: 20211
Vova_1805
Перепробованы ваианты выражения, помещённые в ячейку K3 –
ВСЕ НЕПРАВИЛЬНЫЕ:
Помещал поди неправильно Картинка с другого сайта.

Ввести в К3 формулу

=СУММ(($A$2:$F$5=$K$2)*($A$1:$F$1=$K$1))


и нажать Ctrl-Shift-Enter.
5 янв 20, 18:47    [22053806]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529
автор
Помещал поди неправильно Картинка с другого сайта.

Ввести в К3 формулу

=СУММ(($A$2:$F$5=$K$2)*($A$1:$F$1=$K$1))


и нажать Ctrl-Shift-Enter.


К сообщению приложен файл. Размер - 14Kb
8 янв 20, 16:01    [22054971]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529
Высылаю .xls, чтобы не набиать содежимое листа

К сообщению приложен файл (Array in Excel2.xls - 28Kb) cкачать
8 янв 20, 16:32    [22055003]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Synoptic
Member

Откуда:
Сообщений: 145
Vova_1805, приложил.
После ввода формулы нужно было нажать Ctrl-Shift-Enter.

К сообщению приложен файл (Array in Excel2.xls - 28Kb) cкачать
9 янв 20, 05:21    [22055273]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529
автор
После ввода формулы нужно было нажать Ctrl-Shift-Enter.

Как только правильная формула введена, в данном случае в ячейку K3,
сазу выводится результат и не надо нажимать Ctrl-Shift-Enter.

Кажется, кто-то ответил, что вместо 0 должно быть 3?

К сообщению приложен файл. Размер - 13Kb
9 янв 20, 13:56    [22055556]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Synoptic
Member

Откуда:
Сообщений: 145
Vova_1805
После ввода формулы нужно было нажать Ctrl-Shift-Enter.

Как только правильная формула введена, в данном случае в ячейку K3,
сазу выводится результат и не надо нажимать Ctrl-Shift-Enter.
[/quote] Ctrl-Shift-Enter используется для формул, которые работают с массивами

автор
Кажется, кто-то ответил, что вместо 0 должно быть 3?
Чтобы в К3 был не ноль, нужно заполнить параметры - К1 и К2
10 янв 20, 08:06    [22056097]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529
Synoptic,
Вы решили, поздравляю Вас с успехом!
1) как только указатель мыши поставлю в строку формул, то левая и правая фигурная скобки исчезнут!
Я литературу по этому поводу не читал! Где почитать по поводу ещё символа "*" в формуле?
формула приобретает вид:
=SUM(($A$2:$F$5=$K$2)*($A$1:$F$1=$K$1))
Почему окаймляющие фигурные скобки в формуле исчезают?
– при сохранении “Array in Excel4.xls” какой тип файла надо выбрать, “Книга Excel 97-2003” /
Книга Excel / Двоичная книга Excel ?
Спасибо.

К сообщению приложен файл. Размер - 14Kb
10 янв 20, 14:18    [22056495]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529


К сообщению приложен файл. Размер - 36Kb
10 янв 20, 16:08    [22056627]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Synoptic
Member

Откуда:
Сообщений: 145
Vova_1805

1) как только указатель мыши поставлю в строку формул, то левая и правая фигурная скобки исчезнут!
Я литературу по этому поводу не читал! Где почитать по поводу ещё символа "*" в формуле?
Поищите в гугле "массивы в excel"
Vova_1805
формула приобретает вид:
=SUM(($A$2:$F$5=$K$2)*($A$1:$F$1=$K$1))
Почему окаймляющие фигурные скобки в формуле исчезают?
Потому что эти скобки не вводятся руками. Есл мы редактируем формулу и нам нужно сохранить скобки, то после редактирования нужно нажать ctrl+shift+enter. Этой комбинацией заканчивается любой ввод формул массивов.
Vova_1805
– при сохранении “Array in Excel4.xls” какой тип файла надо выбрать, “Книга Excel 97-2003” /
Книга Excel / Двоичная книга Excel ?
Вы можете выбрать любой формат. Массивы поддерживаются даже в обычном xls.

Vova_1805
Картинка с другого сайта.
Вероятно формат ячейки не предполагает вычислений. Встаньте на ячейку, нажмите ctrl+1, установите "общий" формат и нажмите Ок. После чего возможно потребуется ещё раз зайти в ячейку и нажать ctrl+shift+enter.

Вообще, массивы - очень мощный инструмент excel, в ряде случаев он позволяет обойтись одной формулой для кучи вычислений. Как пример, приложил таблицу умножения, которая сформирована одной формулой для всего массива.
Это вид листа до ввода формулы (одной формулы в одной ячейке!):

К сообщению приложен файл. Размер - 37Kb
11 янв 20, 06:59    [22057024]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Synoptic
Member

Откуда:
Сообщений: 145
Это после нажатия ctrl+shift+enter.
Т.е. заполнилось всё поле результатов за один раз:

К сообщению приложен файл. Размер - 44Kb
11 янв 20, 06:59    [22057025]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Synoptic
Member

Откуда:
Сообщений: 145
Ну и сам файлик, если вдруг возникнут трудности в понимании картинок

К сообщению приложен файл (Массив.xlsx - 9Kb) cкачать
11 янв 20, 07:00    [22057026]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529
Не всё работает, как написано в теории на сайте
https://exceltable.com/master-klass/massivy-funktciy-excel
Рассмотрим другие примеры использования функций массива Excel – рассчитаем итоговую сумму коммунальных платежей с помощью одной формулы.
1. Выделяем ячейку Е9 (напротив «Итого»).
2. Вводим формулу вида: =СУММ(C3:C8*D3:D8).
3. Нажимаем сочетание клавиш: Ctrl + Shift + Enter. Результат:
у них хорошо, а у меня НЕхорошо:

К сообщению приложен файл (Array in Excel Itogo.xls - 36Kb) cкачать
12 янв 20, 18:37    [22057545]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529
показываю как у меня получалось. Я пробовал 2 варианта,
в одном в столбце К оплате ( "E") удалил все формулы,
только в E9 поместил формулу и нажал
Shift+Ctrl+Enter
Спасибо

К сообщению приложен файл. Размер - 51Kb
12 янв 20, 18:42    [22057547]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Synoptic
Member

Откуда:
Сообщений: 145
Vova_1805, взял твой файлик, ничего не правил:

К сообщению приложен файл. Размер - 101Kb
13 янв 20, 09:34    [22057673]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Synoptic
Member

Откуда:
Сообщений: 145
Vova_1805
Не всё работает, как написано в теории на сайте
https://exceltable.com/master-klass/massivy-funktciy-excel
Рассмотрим другие примеры использования функций массива Excel – рассчитаем итоговую сумму коммунальных платежей с помощью одной формулы.
1. Выделяем ячейку Е9 (напротив «Итого»).
2. Вводим формулу вида: =СУММ(C3:C8*D3:D8).
3. Нажимаем сочетание клавиш: Ctrl + Shift + Enter. Результат:
у них хорошо, а у меня НЕхорошо:
Я вот на картинках вижу ошибки на английском. Может быть нужно написать =SUM(C3:C8*D3:D8) вместо =СУММ(C3:C8*D3:D8)?

Сообщение было отредактировано: 13 янв 20, 09:38
13 янв 20, 09:38    [22057675]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Djois
Member

Откуда: Минск
Сообщений: 25
Synoptic

Для таких задач проще использовать массивы. Тот же результат, но без дополнительных строк:
K3={=СУММ(($A$2:$F$5=$K$2)*($A$1:$F$1=$K$1))}

Снимаю шляпу, массив это то что надо для такой задачи!
13 янв 20, 14:56    [22058022]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529
Synoptic,
поздравляю Вас с очередной ПОБЕДОЙ!
Раньше я пробовал как с SUM так и с СУММ,а в последний раз
не попобовал.
Итак, надо SUM !
Благодарю!
14 янв 20, 13:45    [22058747]     Ответить | Цитировать Сообщить модератору
 Re: Счетесли  [new]
Vova_1805
Member

Откуда:
Сообщений: 529
Synoptic,
Поздравляю Вас с очередной победой!
автор
Я вот на картинках вижу ошибки на английском. Может быть нужно написать =SUM(C3:C8*D3:D8) вместо =СУММ(C3:C8*D3:D8)?

Да, надо SUM !
Я в этот раз не попробовал SUM, обычно так и делаю.
Спасибо,
14 янв 20, 13:53    [22058762]     Ответить | Цитировать Сообщить модератору
Топик располагается на нескольких страницах: 1 2      [все]
Все форумы / Microsoft Office Ответить