Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft Office Новый топик    Ответить
 Отличается конечный результат в формуле  [new]
lexxora
Member

Откуда: xrumer2017.ru
Сообщений: 332
Добрый день
Почему в екселе формула =(49604,34+3325,31)*110/100
Равна 58222,61

А на калькуляторе 58222,615

К сообщению приложен файл (Primer.xlsx - 9Kb) cкачать
26 фев 21, 12:02    [22286806]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
The_Prist
Member

Откуда: www.excel-vba.ru
Сообщений: 1990
lexxora,

Excel неправильно считает. Почему?
В Вашем случае все банально - просто форматом скрыт третий знак. Задайте числовой формат с большим кол-вом знаком после запятой и все будет как на калькуляторе.
26 фев 21, 12:15    [22286820]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
lexxora
Member

Откуда: xrumer2017.ru
Сообщений: 332
Добавил, все равно не то что хотелось бы

К сообщению приложен файл. Размер - 70Kb
26 фев 21, 12:36    [22286838]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
DHDD
Member

Откуда:
Сообщений: 108
lexxora,

К сообщению приложен файл. Размер - 20Kb
26 фев 21, 12:48    [22286851]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
lexxora
Member

Откуда: xrumer2017.ru
Сообщений: 332
Я пример файла приложил
=ОКРУГЛ((B1+B2)*A1/100;2)

Я же использую округление и хочу видеть
58222,62
26 фев 21, 12:55    [22286854]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
DHDD
Member

Откуда:
Сообщений: 108
lexxora,

Чтобы округление всегда выполнялось в большую по модулю сторону, используйте функцию ОКРУГЛВВЕРХ.
Чтобы округление всегда выполнялось до ближайшего меньшего по модулю, используйте функцию ОКРУГЛВНИЗ.
Чтобы число округлялось с нужной кратностью (например, до ближайшего числа, кратного 0,5), используйте функцию ОКРУГЛТ.
26 фев 21, 13:00    [22286858]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
lexxora
Member

Откуда: xrumer2017.ru
Сообщений: 332
Если само число округляю, то норм

А вот через формулу .... не то

Правильны ответ получается, если в скобки взять (110/100) но это придется вносить в ПО доработку...

К сообщению приложен файл. Размер - 43Kb
26 фев 21, 13:00    [22286859]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
The_Prist
Member

Откуда: www.excel-vba.ru
Сообщений: 1990
lexxora
Почему в екселе формула =(49604,34+3325,31)*110/100
Равна 58222,61
А на калькуляторе 58222,615

я написал почему. А оказалось:
lexxora
все равно не то что хотелось бы

lexxora
Я же использую округление и хочу видеть
58222,62

мсье знает толк в извращениях :) Сначала спрашиваете почему результат отличается(хотя он не отличается), а потом оказывается, что сами ОКРУГЛ привернули ничего никому об этом не сказав и результат в итоге почему-то не тот, который Вы придумали :)

ОКРУГЛ использует свои правила округления. Все, что меньше 5 - в меньшую сторону, а что больше-равно - в большую. Поэтому и есть еще такая функция как ОКРУГЛВВЕРХ:
=ОКРУГЛВВЕРХ((B1+B2)*A1/100;2)
Но тут есть нюанс, о котором пишется в статье по данной мной ссылке. Выражение:
=(49604,34+3325,31)*110/100
дает в итоге результат:
58222,6149999999
Возможно поэтому ОКРУГЛ работает не так, как ожидалось.

Сообщение было отредактировано: 26 фев 21, 12:59
26 фев 21, 13:01    [22286861]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
lexxora
Member

Откуда: xrumer2017.ru
Сообщений: 332
=ОКРУГЛВВЕРХ(0,11;1) то же не то.
Мне не нужно с 0,11 получить 0,2

0,2 готов получить, как в школе, если хотя бы 0,15


Сейчас гляну ОКРУГЛТ
26 фев 21, 13:05    [22286864]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
lexxora
Member

Откуда: xrumer2017.ru
Сообщений: 332
=ОКРУГЛТ((B1+B2)*A1/100;2)
дает ответ
58222,0000000

Не подходит
26 фев 21, 13:07    [22286865]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
The_Prist
Member

Откуда: www.excel-vba.ru
Сообщений: 1990
lexxora
=ОКРУГЛВВЕРХ(0,11;1) то же не то.
Мне не нужно с 0,11 получить 0,2

=ОКРУГЛ(ОКРУГЛ(49604,34+3325,31;2)*110/100;2)
в статье по ссылке я это и описывал - надо искать проблемное выражение и его сначала округлять. Тогда результат будет более адекватным.
26 фев 21, 13:08    [22286867]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
lexxora
Member

Откуда: xrumer2017.ru
Сообщений: 332
Спасибо
26 фев 21, 14:04    [22286934]     Ответить | Цитировать Сообщить модератору
 Re: Отличается конечный результат в формуле  [new]
Focha
Member

Откуда: Москва
Сообщений: 598
а какая версия офиса 32 или 64 битная?
5 мар 21, 11:41    [22290164]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft Office Ответить