Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Oracle Новый топик    Ответить
 11g XE - проблема с impdb  [new]
KWK
Member

Откуда:
Сообщений: 7
Здравствуйте.
Волею судьбы вынужден срочно осваивать администрирование оракла почти с нуля, так что не судите строго.

Успешно установил 11g XE (11.2.0) под оракл линукс 6.10. Теперь нужно импортировать определенные схемы из другой базы, тоже 11g XE под линуксом. Экспорт сделан заведомо с помощью expdp. Пытаюсь импортировать impdp'ом, получаю ошибку ORA-39006 Internal error, ORA-39213 Metadata processing is not available. Ничего из того, что прочитал о подобных ситуациях, не оказалось полезным.

Параметры импорта заданы такие:

USERID=system
FULL=Y
EXCLUDE=TABLESPACE
INCLUDE=SCHEMA:"IN ('SCHEMA1', 'SCHEMA2')"
DIRECTORY=dmpdir
LOGFILE=imp.log
DUMPFILE=full.dmp

Каталог dmpdir в БД создан от имени system. Файл xe_full.dmp лежит там, куда указывает dmpdir. Имена табличных пространств, где лежат схемы, одинаковые в исходной и целевой БД. Схем по имени SCHEMA1, SCHEMA2 в целевой БД нет, а в экспортном файле, судя по логу, они есть.

Подскажите чайнику, пожалуйста, что я мог сделать не так.
12 ноя 21, 16:58    [22395211]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
SY
Member

Откуда: Middlebury, CT USA
Сообщений: 10337
connect /@pdb_connection as sysdba
exec sys.dbms_metadata_util.load_stylesheets


SY.
12 ноя 21, 18:52    [22395290]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
KWK
Member

Откуда:
Сообщений: 7
SY, это не работает в ХЕ.
12 ноя 21, 18:54    [22395294]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
Asmodeus
Member

Откуда:
Сообщений: 612
KWK, в alert_<SID>.log есть что-нибудь в это же время?
12 ноя 21, 18:59    [22395296]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
KWK
Member

Откуда:
Сообщений: 7
Asmodeus
KWK, в alert_<SID>.log есть что-нибудь в это же время?


Только что повторил попытку. Только это:

Fri Nov 12 19:56:08 2021
DM00 started with pid=28, OS id=3536, job SYSTEM.SYS_IMPORT_FULL_01
12 ноя 21, 21:00    [22395351]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
SY
Member

Откуда: Middlebury, CT USA
Сообщений: 10337
KWK
SY, это не работает в ХЕ.


С XE никогда не работал. А что не работает?

SY.
12 ноя 21, 21:50    [22395372]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
SQL*Plus
Member

Откуда: Россия, Москва
Сообщений: 8544
KWK,

Вспышка моей памяти предполагает, что был какой-то баг похожий именно для 11g XE.
По-моему, каких-то процедур не хватало или пакетов или файлов.
Брали это недостающее от EE или SE.

Поищите по форуму.
Предполагаю, что должно тут быть.

Народ, может кто-то вспомнит?
12 ноя 21, 21:58    [22395379]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
KWK
Member

Откуда:
Сообщений: 7
SY
KWK
SY, это не работает в ХЕ.


С XE никогда не работал. А что не работает?

SY.

Не пoддерживаются xmltype и ява.
12 ноя 21, 22:14    [22395386]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
KWK
Member

Откуда:
Сообщений: 7
SQL*Plus, спасибо за идею, не исключено, что рабочий сервер доработан напильником, надо проверить.
12 ноя 21, 22:19    [22395389]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
KWK
Member

Откуда:
Сообщений: 7
Провел опыт: в базу 11 ХЕ, установленную до меня, импортировал схему из того же дампа с теми же параметрами.
И все получилось.

Вопросы остаются прежними: удавалось ли кому-то заставить работать impdp на ХЕ? Если да, то какие потребовались заклинания?

Я могу, конечно, тупо целиком скопировать рабочую установку на новую систему, но все же хотелось бы разобраться.
15 ноя 21, 12:18    [22396123]     Ответить | Цитировать Сообщить модератору
 Re: 11g XE - проблема с impdb  [new]
KWK
Member

Откуда:
Сообщений: 7
Стоп машина. Проблема решена. Докладываю.

Коллега SY с самого начала дал правильный совет. Более того, это было первое, что я пробовал, но что-то делал не так и процедура load_stylesheets не выполнялась.

Сейчас заново скопировал в $ORACLE_HOME/rdbms/xml каталог xsl с содержимым (в ХЕ его изначально нет), выполнил sys.dbms_metadata_util.load_stylesheets от имени sys, и все заработало.

Всем большое спасибо, SY - в особенности.
15 ноя 21, 12:48    [22396146]     Ответить | Цитировать Сообщить модератору
Все форумы / Oracle Ответить