Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft Access Новый топик    Ответить
 То ли глюк, то ли я чего-то не знаю.  [new]
Николай
Guest
Здравствуйте.
Ситуация такова: Существует форма, на которой несколько полей со списком.
Существует запрос, который использует данные из этих полей со списком.
Но почему запрос "видит" только одно, причем активное поле со списком.
Остальные для него не существуют. Причем если ни одно поле со списком не имеет фокуса.
(Не активно, курсор не на нем), то запрос не видит ни одного поля.
Помогите разобраться.
Я создал новую базу данных, там только две таблицы, одна форма, один запрос.
На форме два поля с списком. Запрос ипользует данные одного поля.
Если это поле активно, запрос работает.
Если активно другое, уже не работает.
Пожалуйста помогите!
30 июл 01, 14:07    [124]     Ответить | Цитировать Сообщить модератору
 RE:То ли глюк, то ли я чего-то не знаю.  [new]
AlexUnik
Guest
Какая у Вас версия Access, установлены ли SR-ки, как назначается источник данных для списков, как Вы обращаетесь в запросе к названию поля со списком?
31 июл 01, 05:21    [125]     Ответить | Цитировать Сообщить модератору
 RE:То ли глюк, то ли я чего-то не знаю.  [new]
cube
Guest
... и самое главное: ЗАЧЕМ из запроса обращаться к каким-то бренным полям формы, которых завтра может и не быть?
31 июл 01, 05:26    [126]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft Access Ответить