Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Oracle Новый топик    Ответить
 18 патч на Forms  [new]
Sqaimes
Member

Откуда: Украина, Мариуполь
Сообщений: 443
Есть Oracle Dev.6i for Linux и патч 18 для него же под Linux.
Он ставится на голый формс или уже на пропатченный каким либо предыдущим патчем?
15 мар 06, 09:39    [2449188]     Ответить | Цитировать Сообщить модератору
 Re: 18 патч на Forms  [new]
AI
Member

Откуда: Москва
Сообщений: 2817
Прочитать readme к патчу религия не позволяет?
15 мар 06, 09:59    [2449282]     Ответить | Цитировать Сообщить модератору
 Re: 18 патч на Forms  [new]
Sqaimes
Member

Откуда: Украина, Мариуполь
Сообщений: 443
Уважаемый Al! Ткни свой религиозный нос сюда, и если знаешь то скажи , нечего flame разводить, я просто так бы неспрашивал!!!:

& Reports 6i Patch 18 for Linux

January 2006

Note for E-Business Suite Customers:

The Oracle E-Business Suite is a complete set of business applications
that runs entirely on the internet. E-Business Suite Users must first
see [1]Upgrading Developer 6i with Oracle Applications 11i and refer
to this readme file only when that note so states. This note can be
obtained via MetaLink -> Technical Libraries -> ERP Applications ->
Applications Technology Stack under D2K Forms Issues, Setup & Usage

Note: You should be logged in as the oracle user with write previleges
to the ORACLE_HOME.(ie. You have write permission to all the files
under $ORACLE_HOME)

Installation Instructions

1. Set your ORACLE_HOME.
2. If you are going to apply this patch on top of an iAS install:
Set ORACLE_HOME to <iAS_HOME>/6iserver
Prepend <iAS_HOME>/6iserver/bin to the *beginning* of PATH
Prepend <iAS_HOME>/6iserver/lib to the *beginning* of LD_LIBRARY_PATH
3. Copy the files in this patch to your $ORACLE_HOME.
4. Unzip the patch using either WinZip on NT or unzip on Unix.
5. Run the install script contained in the patch:
cd $ORACLE_HOME/developer6i_patch18
./patch_install.sh 2>&1 | tee patch_install_p18.log (ksh)
./patch_install.sh |& tee patch_install_p18.log (csh)
6. Check patch_install_p18.log for errors.
7. Relink Procedure Builder, Forms, Graphics and Reports:
cd $ORACLE_HOME/procbuilder60/lib; make -f ins_procbuilder.mk install
cd $ORACLE_HOME/forms60/lib; make -f ins_forms60w.mk install
cd $ORACLE_HOME/graphics60/lib; make -f ins_graphics60w.mk install
Reports has both link-time and run-time dependency with libjava.so
so you need to append either one of:
$ORACLE_HOME/network/jre11/lib/linux/native_threads
$ORACLE_HOME/network/jre11/lib/i686/native_threads
in $LD_LIBRARY_PATH before linking Reports.
Please check your files under $ORACLE_HOME/network/jre11/lib to
see which one of the above is appropriate on your system. The same
$LD_LIBRARY_PATH should be used at run-time.
cd $ORACLE_HOME/reports60/lib; make -f ins_reports60w.mk install
15 мар 06, 10:16    [2449357]     Ответить | Цитировать Сообщить модератору
 Re: 18 патч на Forms  [new]
Sqaimes
Member

Откуда: Украина, Мариуполь
Сообщений: 443
Я так и ставил по readme!!!!!!!!!!!!
забыл... в строчке:
cd $ORACLE_HOME/forms60/lib; make -f ins_forms60w.mk install

/usr/bin/ld -o /opt/ora_dev/product/6i/lib/libifjapi60.so -z muldefs -G -L/opt/ora_dev/product/6i/lib/ context.o create.o destroy.o formsapi.o iauasst.o iauexcep.o ifjapi.o objlib.o persistc.o /opt/ora_dev/product/6i/lib/libifjapi60.a /opt/ora_dev/product/6i/forms60/lib/ipcpcr.o /opt/ora_dev/product/6i/forms60/lib/ipdecr.o /opt/ora_dev/product/6i/forms60/lib/ipkbu.o sslidtab.o -ld2f -lie -lil -lie -lig -lifg -lig -limg -liwg -lidd -lidl -lidg -lid2 -lidg -lid1 -ligo -litg -lihm -lib1 -limg -lipg -licg -lipc -limc -lifc -liwc -liplsd -liod -lioc -lic -lsosd -liic -lit -lic -lipc -lnn60 -lobx60 -lzrc60 -lge60 -lvgs60 -lde60 -lucol60 -lca60 -lnvu60 -lnvc60 -lnvs60 -luicc60 -lmma60 -lmmiw60 -lmmov60 -lmma60 -lmmos60 -lmmoi60 -lmmia60 -lmmft60 -lmmcm60 -luihx60 -luc60 -luipr60 -luimotif60 -lot60 -lrem60 -lree60 -lrec60 -luiimg60 -luimotif60 -luipr60 -luiimg60 -luc60 -lrem60 -luimotif60 -luia60 -ltknqap60 -luipr60 -luimotif60 -lutt60 -lix60 -lixd60 -lrod60 -lror60 -lros60 -lrod60 -lror60 -lros60 -lrod60 -luat60 -lutc60 -lutl60 -lutsl60 -lplsf -lplsb -lextp -lpsd -lplsf -lplsb -lextp -lslax -lsql /opt/ora_dev/product/6i/lib/nautab.o /opt/ora_dev/product/6i/lib/naeet.o /opt/ora_dev/product/6i/lib/naect.o /opt/ora_dev/product/6i/lib/naedhs.o -lnetv2 -lnttcp -lnetwork_d -lnz -lnzr -lnsslb8 -lbcert -lncr -lnetv2 -lnttcp -lnetwork_d -lnz -lnzr -lnsslb8 -lbcert -lclient -lvsn -lcommon -lgeneric -lmm -lnlsrtl3 -lcore4 -lnlsrtl3 -lcore4 -lnlsrtl3 -lnetv2 -lnttcp -lnetwork_d -lnz -lnzr -lnsslb8 -lbcert -lncr -lnetv2 -lnttcp -lnetwork_d -lnz -lnzr -lnsslb8 -lbcert -lclient -lvsn -lcommon -lgeneric -lepc -lnlsrtl3 -lcore4 -lnlsrtl3 -lcore4 -lnlsrtl3 -lclient -lvsn -lcommon -lgeneric -lnlsrtl3 -lcore4 -lnlsrtl3 -lcore4 -lnlsrtl3 -ldl -lm -lpthread -ldl -lpthread -lm -L/usr/lib -lm -L/usr/X11R6/lib -lXm -L/usr/X11R6/lib/ -L/usr/X11R6/lib/ -lXt -lX11 -lm -lix60 -lixd60 -lX11 -lnlsrtl3 -lXp -lXext -Bdynamic -lnsl -ldl -lm -lc -Bstatic
/usr/bin/ld: -static and -shared may not be used together
make: *** [/opt/ora_dev/product/6i/lib/libifjapi60.so] Ошибка 1
15 мар 06, 10:32    [2449439]     Ответить | Цитировать Сообщить модератору
Все форумы / Oracle Ответить