Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Вопрос-Ответ Новый топик    Ответить
 Про макросы  [new]
Andrei_A
Member

Откуда: СПб
Сообщений: 255
Может кто знает. Вставляю из макроса в тексте формулу например "=СУММ(A1:A6)". На листе в итоге #ИМЯ?. Нажимаю в ячейку, показывает именно нужный диапазон, нажимаю Enter - появляется число. В чем прикол и как заставить число сразу появляться?
7 апр 03, 17:32    [166940]     Ответить | Цитировать Сообщить модератору
 Re: Про макросы  [new]
mahoune
Member

Откуда: Moscow
Сообщений: 5653
В формате ячейки когда-то стояло тип данных "Текстовое" или еще что-то, но не "Общий". Я так и не нашел как это победить...
8 апр 03, 12:26    [167719]     Ответить | Цитировать Сообщить модератору
 Re: Про макросы  [new]
AndreK
Member

Откуда:
Сообщений: 3251
А в адресах ячеек часом не русские "А"? А?
11 апр 03, 08:15    [171160]     Ответить | Цитировать Сообщить модератору
 Re: Про макросы  [new]
Andrei_A
Member

Откуда: СПб
Сообщений: 255
Нет. Что ж вы меня за кого считаете. Более того, стал ковыряться, смотрел как выполняется формула - он не распознает не диапазон, а саму формулу. Не может понять что такое =Сумм. Вообщем написал просто свою функцию и ее вызываю 8-)
11 апр 03, 09:43    [171243]     Ответить | Цитировать Сообщить модератору
Все форумы / Вопрос-Ответ Ответить