Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Вопрос-Ответ Новый топик    Ответить
 отчет в 1с  [new]
fang86
Member

Откуда:
Сообщений: 1
помогите пожалуйста! как сформировать отчет в 1с! а конкретнее необходимо ФИО, паспортные данные, прописка
24 ноя 06, 13:18    [3446875]     Ответить | Цитировать Сообщить модератору
 Re: отчет в 1с  [new]
AsPiro
Member

Откуда: Ангарск
Сообщений: 599
fang86
помогите пожалуйста! как сформировать отчет в 1с! а конкретнее необходимо ФИО, паспортные данные, прописка
Одинэсники! Вам что http://mista.ru и подобных форумов мало??? Какого фига вы сюда свой бред выплёвываете? Здесь всёравно никто не угадает какая у Вас версия 1С и в каком справочнике у Вас ФИО храниться...
27 ноя 06, 11:40    [3454122]     Ответить | Цитировать Сообщить модератору
 Re: отчет в 1с  [new]
klen_
Member

Откуда:
Сообщений: 2404
Процедура Сформировать()
	Перем целСч; // счётчик
	целСч = 0;
	НазваниеОрганизации= Константа.НазваниеОрганизации;
	спрСотр = СоздатьОбъект("Справочник.Сотрудники");
	Таб = СоздатьОбъект("Таблица");
	Таб.ИсходнаяТаблица("ВашаТаблица");
	Таб.ВывестиСекцию("Шапка");
	Состояние("Заполнение таблицы");
	спрСотр.ИспользоватьДату(РабочаяДата());
	спрСотр.ПорядокНаименований();
	спрСотр.ВыбратьЭлементы(0);
	НПП = 1;
	Пока спрСотр.ПолучитьЭлемент() = 1 Цикл
		Если (спрСотр.ЭтоГруппа() = 0) И (спрСотр.ПометкаУдаления() = 0) Тогда
			Если ((спрСотр.СостояниеФизлица = Перечисление.СостояниеФизлица.СотрудникОсновной) Или
				  (спрСотр.СостояниеФизлица = Перечисление.СостояниеФизлица.ВременноНеРаботает)) И
				  (спрСотр.Ставка > 0) И (спрСотр.ОсновнойЭлемент = спрСотр.ТекущийЭлемент()) Тогда
			
				пасп_ = СокрЛП( спрСотр.ДокументУдЛичность );

				Таб.ВывестиСекцию("Строка");
				
			КонецЕсли;
		КонецЕсли;
		целСч = целСч + 1;
		Состояние("Обработано: " + целСч + ".");
	КонецЦикла;
	Таб.Опции(0, 0, 2, 0, "ПФР");
	Таб.ПараметрыСтраницы(1,100,,20,10,10,10,10,5,);
	//Таб.ПовторятьПриПечатиСтолбцы(1,2);
	Таб.ПовторятьПриПечатиСтроки(1,2);
	Таб.ТолькоПросмотр(1);
	Таб.Показать("Печать ПФР",);
КонецПроцедуры
27 ноя 06, 13:24    [3454998]     Ответить | Цитировать Сообщить модератору
 Re: отчет в 1с  [new]
klen_
Member

Откуда:
Сообщений: 2404
Модераторы. Может быть перенесёте в ERP и учётные системы, вдруг пригодится.
27 ноя 06, 15:19    [3456238]     Ответить | Цитировать Сообщить модератору
 Re: отчет в 1с  [new]
tchingiz
Member

Откуда:
Сообщений: 38152
erp это 1с чтоли?
27 ноя 06, 22:53    [3458633]     Ответить | Цитировать Сообщить модератору
Все форумы / Вопрос-Ответ Ответить