Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Oracle Новый топик    Ответить
 EXP/IMP 8.1.7 => 9.2  [new]
GadFly
Member

Откуда:
Сообщений: 21
ПЕРЕНОШУ СХЕМУ с помощью PLSQL Developer, долго что-то делает, в итоге что-то переноситься что-то нет, причем то что не переноситься - самое важное ес-но, ругается кажется на ключи еще что-то...
Давно в документации где-то таблицу видел мол должно все переноситься....
может когда импортируешь в 9.2 нужно imp.exe брать из 8.1.7 или без разницы?
Спасибо.
2 фев 07, 17:35    [3733443]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
Sevick
Member

Откуда: из-за компа
Сообщений: 833
GadFly
ПЕРЕНОШУ СХЕМУ с помощью PLSQL Developer, долго что-то делает, в итоге что-то переноситься что-то нет, причем то что не переноситься - самое важное ес-но, ругается кажется на ключи еще что-то...
Давно в документации где-то таблицу видел мол должно все переноситься....
может когда импортируешь в 9.2 нужно imp.exe брать из 8.1.7 или без разницы?
Спасибо.


Перед заливкой неплохо было бы отключать constraints....
2 фев 07, 17:42    [3733503]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
GadFly
Member

Откуда:
Сообщений: 21
Sevick
GadFly
ПЕРЕНОШУ СХЕМУ с помощью PLSQL Developer, долго что-то делает, в итоге что-то переноситься что-то нет, причем то что не переноситься - самое важное ес-но, ругается кажется на ключи еще что-то...
Давно в документации где-то таблицу видел мол должно все переноситься....
может когда импортируешь в 9.2 нужно imp.exe брать из 8.1.7 или без разницы?
Спасибо.


Перед заливкой неплохо было бы отключать constraints....


Дык он их на автомате отрубать должен, разве нет?
2 фев 07, 17:45    [3733527]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
tru55
Member

Откуда: СПб
Сообщений: 19790
Дык он их на автомате отрубать должен, разве нет?

Это кто сказал?
Особенно, если одновременно работают пользователи...
2 фев 07, 17:46    [3733541]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
GadFly
Member

Откуда:
Сообщений: 21
tru55
Дык он их на автомате отрубать должен, разве нет?

Это кто сказал?
Особенно, если одновременно работают пользователи...


Глупый наверно вопрос но куда деваться:
А как их отрубить тады?
Дали скрипт - он подвисает, еще как-нить можно?
Через навигатор или там девелопер?
6 фев 07, 17:15    [3746117]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
SQL*Plus
Member

Откуда: Россия, Москва
Сообщений: 8131
GadFly
tru55
Дык он их на автомате отрубать должен, разве нет?
Это кто сказал?
Особенно, если одновременно работают пользователи...
Глупый наверно вопрос но куда деваться:
А как их отрубить тады?
Дали скрипт - он подвисает, еще как-нить можно?
Через навигатор или там девелопер?
Расскажите по порядку что вы делаете и с какой целью.
Точно укажите
-- версии баз данных
-- версии утилит exp и imp
-- какие именно ошибки вы получаете и какая утилита их вам возвращает
-- что-то еще, что считаете важным.

Может помочь эта ссылка
6 фев 07, 17:21    [3746151]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
GadFly
Member

Откуда:
Сообщений: 21
SQL*Plus
GadFly
tru55
Дык он их на автомате отрубать должен, разве нет?
Это кто сказал?
Особенно, если одновременно работают пользователи...
Глупый наверно вопрос но куда деваться:
А как их отрубить тады?
Дали скрипт - он подвисает, еще как-нить можно?
Через навигатор или там девелопер?
Расскажите по порядку что вы делаете и с какой целью.
Точно укажите
-- версии баз данных
-- версии утилит exp и imp
-- какие именно ошибки вы получаете и какая утилита их вам возвращает
-- что-то еще, что считаете важным.

Может помочь эта ссылка



-- версии баз данных \\8.1.7
-- версии утилит exp и imp \\8.1.7 (оттуда же)
-- какие именно ошибки вы получаете и какая утилита их вам возвращает \\ imp ругается пишет что-то про констрейнты, вот в частности:
IMP-00019: row rejected due to ORACLE error 1
IMP-00003: ORACLE error 1 encountered
ORA-00001: unique constraint <USER1.ATR_PK> violeted

-- что-то еще, что считаете важным. \\стоят базы под HP-UX 11 (exp/imp соответственно не exe-шные)
6 фев 07, 17:42    [3746296]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
SQL*Plus
Member

Откуда: Россия, Москва
Сообщений: 8131
GadFly
SQL*Plus
GadFly
tru55
Дык он их на автомате отрубать должен, разве нет?
Это кто сказал?
Особенно, если одновременно работают пользователи...
Глупый наверно вопрос но куда деваться:
А как их отрубить тады?
Дали скрипт - он подвисает, еще как-нить можно?
Через навигатор или там девелопер?
Расскажите по порядку что вы делаете и с какой целью.
Точно укажите
-- версии баз данных
-- версии утилит exp и imp
-- какие именно ошибки вы получаете и какая утилита их вам возвращает
-- что-то еще, что считаете важным.

Может помочь эта ссылка

-- версии баз данных \\8.1.7
-- версии утилит exp и imp \\8.1.7 (оттуда же)
-- какие именно ошибки вы получаете и какая утилита их вам возвращает \\ imp ругается пишет что-то про констрейнты, вот в частности:
IMP-00019: row rejected due to ORACLE error 1
IMP-00003: ORACLE error 1 encountered
ORA-00001: unique constraint <USER1.ATR_PK> violeted

-- что-то еще, что считаете важным. \\стоят базы под HP-UX 11 (exp/imp соответственно не exe-шные)
Расскажите по порядку что вы делаете и с какой целью.

Из вашего ответа следует, что база-источник и целевая база версий 8.1.7.
Почему обсуждаемую тему вы озаглавили "EXP/IMP 8.1.7 => 9.2"?
6 фев 07, 17:48    [3746324]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
GadFly
Member

Откуда:
Сообщений: 21
SQL*Plus

Из вашего ответа следует, что база-источник и целевая база версий 8.1.7.
Почему обсуждаемую тему вы озаглавили "EXP/IMP 8.1.7 => 9.2"?

да тут уже без разницы куда, главное перекинуть-таки, на базе откуда перекидываю ошибочка случилася остался от неё тока dump, вот я и пытаюсь его хоть на 8.1.7 под HP-UX закинуть, хоть на 9.2 под Windows, и туда и туда одно и тоже получается, просто я сначала на 9.2 кидал, потм подумал может проблемы с совместимостью и начал на 8.1.7 но от 9.2 я еще не отказался...
6 фев 07, 17:55    [3746384]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
констрэйнт
Guest
GadFly
ORA-00001: unique constraint <USER1.ATR_PK> violeted


Судя по сообщению в базе уже есть такой констрэйнт.

Дропните своего USER1 каскадом и создайте заново.
6 фев 07, 18:01    [3746429]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
SQL*Plus
Member

Откуда: Россия, Москва
Сообщений: 8131
GadFly
SQL*Plus

Из вашего ответа следует, что база-источник и целевая база версий 8.1.7.
Почему обсуждаемую тему вы озаглавили "EXP/IMP 8.1.7 => 9.2"?

да тут уже без разницы куда, главное перекинуть-таки, на базе откуда перекидываю ошибочка случилася остался от неё тока dump, вот я и пытаюсь его хоть на 8.1.7 под HP-UX закинуть, хоть на 9.2 под Windows, и туда и туда одно и тоже получается, просто я сначала на 9.2 кидал, потм подумал может проблемы с совместимостью и начал на 8.1.7 но от 9.2 я еще не отказался...
Загружать утилитой импорт, соответствующей целевой базе данных (В базу Oracle 9.2.0.8 грузить утилитой версии imp версии 9.2.0.8).
Протокол импорта писать в файл.

Когда задаете вопросы, приводить фрагменты протокола, а не ваши ощущения.
Версии всегда приводите с точностью до 4-й группы цифр.
Например, Oracle 8.1.7.4 Enterprise Edition for Windows, Oracle 9.2.0.6 for HP UX, e.t.c.
6 фев 07, 18:03    [3746453]     Ответить | Цитировать Сообщить модератору
 Re: EXP/IMP 8.1.7 => 9.2  [new]
SQL*Plus
Member

Откуда: Россия, Москва
Сообщений: 8131
tru55
Дык он их на автомате отрубать должен, разве нет?

Это кто сказал?
Особенно, если одновременно работают пользователи...
При импорте схемы ограничения включаются после загрузки данных.
Сначала Primary Key и Unique, затем Foreign Key.
По крайней мере так было в 8.1.7.
6 фев 07, 18:06    [3746464]     Ответить | Цитировать Сообщить модератору
Все форумы / Oracle Ответить