Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Oracle Новый топик    Ответить
 Perl, Oracle  [new]
AngelOfDarkness
Member

Откуда:
Сообщений: 5
Доброго времени суток. Такая проблемка. Есть скрипт на perl-е, который работает с базой данных Oracle.
Если запускать скрипт с консоли, то все работает нормально. Если запускать его через браузер, то выводится сообщение "Internal Server Error", а в файле логов пишется
DBI connect('host=xxx.xxx.xxx.xxx;sid=database;port=xxxx','login',...) failed: ORA-01017: invalid username/password; logon denied (DBD ERROR: OCISessionBegin)
Может кто сталкивался с такой проблемой, подскажите, пожалуйста, что делать
14 май 08, 11:21    [5660127]     Ответить | Цитировать Сообщить модератору
 Re: Perl, Oracle  [new]
Попрошайка
Guest
Написано практически русским языком

ORA-01017: invalid username/password; logon denied
14 май 08, 12:04    [5660573]     Ответить | Цитировать Сообщить модератору
 Re: Perl, Oracle  [new]
AngelOfDarkness
Member

Откуда:
Сообщений: 5
Я знаю, что эта ошибка означает непраивльный логин и пароль. Вопрос в том, что тот же самый скрипт с теми же самыми логином и паролем работает, если ега запустить с консоли. А вот через браузер (т.е. через апач) работать не хочет
14 май 08, 12:56    [5661086]     Ответить | Цитировать Сообщить модератору
 Re: Perl, Oracle  [new]
hell
Member

Откуда:
Сообщений: 3001
AngelOfDarkness
Я знаю, что эта ошибка означает непраивльный логин и пароль. Вопрос в том, что тот же самый скрипт с теми же самыми логином и паролем работает, если ега запустить с консоли. А вот через браузер (т.е. через апач) работать не хочет


смотреть в каком окружении запускается скрипт и из консоли...
14 май 08, 12:59    [5661114]     Ответить | Цитировать Сообщить модератору
 Re: Perl, Oracle  [new]
orawish
Member

Откуда: Гадюкино-2 (City)
Сообщений: 15487
AngelOfDarkness
Я знаю, что эта ошибка означает непраивльный логин и пароль. Вопрос в том, что тот же самый скрипт с теми же самыми логином и паролем работает, если ега запустить с консоли. А вот через браузер (т.е. через апач) работать не хочет

вероятно, в настройке (толстого) клиента вашего есть нечто (напр. os идентификация), о чём браузер недотелепатил (всилу естественных причин ;). Ну или, что вероятнее, у вас просто глаз замылился..
14 май 08, 13:09    [5661212]     Ответить | Цитировать Сообщить модератору
Все форумы / Oracle Ответить