Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / PowerBuilder Новый топик    Ответить
 Не действуют символы переноса строки в Multilineedit  [new]
shurakm1
Member

Откуда:
Сообщений: 30
Есть длинная строка (текст) с переносами Char(13)+Char(10)
При присвоении свойству Multilineedit.text этой строки эти символы выводятся как квадратики
как с этим побороться?
4 мар 09, 15:11    [6886893]     Ответить | Цитировать Сообщить модератору
 Re: Не действуют символы переноса строки в Multilineedit  [new]
Локшин Марк
Member

Откуда: Воронеж
Сообщений: 3154
Переносы должны работать.
4 мар 09, 15:23    [6887005]     Ответить | Цитировать Сообщить модератору
 Re: Не действуют символы переноса строки в Multilineedit  [new]
18-я весна
Member

Откуда: Odessa
Сообщений: 203
shurakm1
Есть длинная строка (текст) с переносами Char(13)+Char(10)
При присвоении свойству Multilineedit.text этой строки эти символы выводятся как квадратики
как с этим побороться?

Убедитесь, что действительно Char(13)+Char(10) (оно же "~r~n")
Если строка получена считыванием из файла в текстовом режиме, то в этом случае в ней пары "~r~n" могли замениться на "~n". А это не является правильным переводом для MLE, так же как и "~r" и "~n~r".
Насчет квадратов не уверен, наверно от версии PB зависит.
4 мар 09, 16:25    [6887397]     Ответить | Цитировать Сообщить модератору
 Re: Не действуют символы переноса строки в Multilineedit  [new]
shurakm1
Member

Откуда:
Сообщений: 30
18-я весна,

Спасибо, так и есть: в бд лежит 0D0A,а в билдер идет только 0A
мда...
4 мар 09, 16:39    [6887511]     Ответить | Цитировать Сообщить модератору
Все форумы / PowerBuilder Ответить