Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / ADO.NET, LINQ, Entity Framework, NHibernate, DAL, ORM Новый топик    Ответить
 ADO+MSSQL вопросы  [new]
Iojkin_Kot
Member

Откуда:
Сообщений: 1
1. Хочу получить список таблиц БД "ruo":
Соединение = CreateObject("ADODB.Connection");
Попытка
	Соединение.Open("Provider=SQLOLEDB.1;Password="""";Persist Security Info=True;User ID=sa;Initial Catalog=ruo;Data Source=localhost");
Исключение
	Сообщить("Не возможно подключиться к базе!", "!");
	Сообщить(ОписаниеОшибки(), "!");
	Возврат;
КонецПопытки;

Каталог = CreateObject("ADOX.Catalog");
Каталог.ActiveConnection = Соединение;

Таблицы = Каталог.Tables;
	
Для к=0 По Таблицы.Count-1 Цикл
	Сообщить(Таблицы.Item(к).Name);
КонецЦикла;
Выводит все таблицы sql сервера. Нужны только таблицы БД "ruo". Знаю что можно сделать через OpenSheme или SQL запрос, но нужно через ADOX.

2. Далее пробую получить все представления (Views):
Представления = Каталог.Views;
	
Для к=0 По Представления.Count-1 Цикл
	Сообщить(Представления.Item(к).Name);
КонецЦикла;
Здесь вообще валится с ошибкой: "ADOX.Views: Object or provider is not capable of performing requested operation." Полагаю нужны права на чтение представлений?

3. Та же самая ошибка появляется, когда пытаюсь прочитать коллекцию колонок у ключа:
Ключи = Таблица.Keys;
Для к=0 По Ключи.Count-1 Цикл
	Колонки = Ключи.Item(к).Columns;
	Для л=0 По Колонки.Count-1 Цикл
		Сообщить(Колонки.Item(л).Name);
	КонецЦикла;
КонецЦикла;
29 май 09, 22:01    [7246832]     Ответить | Цитировать Сообщить модератору
Все форумы / ADO.NET, LINQ, Entity Framework, NHibernate, DAL, ORM Ответить