Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft SQL Server Новый топик    Ответить
 master + ENABLE_BROKER = Error( 5058 )  [new]
Greenhorn
Member

Откуда:
Сообщений: 311
Добрый день...

Захотелось мне сварганить небольшую автоматику по обслуживанию всех баз одного инстанса...
А для распараллеливания задач этой автоматики, решил воспользоваться service broker_ом.
Т.к. задача касается всех баз, то автоматику решил разместить в базе master
И...
ALTER DATABASE master set ENABLE_BROKER
---
Msg 5058, Level 16, State 8, Line 1
Option 'ENABLE_BROKER' cannot be set in database 'master'.
Хотя в BOL_е
Примечание.
Для включения в любой базе данных компонента SQL Server Service Broker необходима блокировка базы данных.
Чтобы включить компонент Service Broker в базе данных msdb, первым делом необходимо остановить службу агента SQL Server, чтобы компонент Service Broker смог получить необходимую блокировку.

И нигде не сказано о Option 'ENABLE_BROKER' cannot be set in database 'master'.

Вопрос - Так можно ли включить брокера на мастере или нет ?
Если можно, то как ?
25 сен 09, 13:24    [7708028]     Ответить | Цитировать Сообщить модератору
 Re: master + ENABLE_BROKER = Error( 5058 )  [new]
ТАРАКАН
Member

Откуда:
Сообщений: 439
ALTER DATABASE msdb
SET ENABLE_BROKER
25 сен 09, 13:29    [7708072]     Ответить | Цитировать Сообщить модератору
 Re: master + ENABLE_BROKER = Error( 5058 )  [new]
pkarklin
Member

Откуда: Москва (Муром)
Сообщений: 74927
Используйте msdb.
25 сен 09, 13:33    [7708092]     Ответить | Цитировать Сообщить модератору
 Re: master + ENABLE_BROKER = Error( 5058 )  [new]
Greenhorn
Member

Откуда:
Сообщений: 311
ТАРАКАН,

Речь о мастере !

P.S. Хотя, как вариант, можно и msdb поиметь. Но хочется разобраться ...
25 сен 09, 13:34    [7708100]     Ответить | Цитировать Сообщить модератору
 Re: master + ENABLE_BROKER = Error( 5058 )  [new]
pkarklin
Member

Откуда: Москва (Муром)
Сообщений: 74927
Greenhorn
Хотя, как вариант, можно и msdb поиметь. Но хочется разобраться ...


Не стоит. Вам сервер уже все сказал.
25 сен 09, 13:44    [7708159]     Ответить | Цитировать Сообщить модератору
 Re: master + ENABLE_BROKER = Error( 5058 )  [new]
Maxx
Member [скрыт]

Откуда:
Сообщений: 24290
автор
ENABLE_BROKER requires an exclusive database lock. If other sessions have locked resources in the database, ENABLE_BROKER will wait until the other sessions release their locks. To enable Service Broker in a user database, ensure that no other sessions are using the database before you run the ALTER DATABASE SET ENABLE_BROKER statement, such as by putting the database in single user mode. To enable Service Broker in the msdb database, first stop SQL Server Agent so that Service Broker can obtain the necessary lock.


Думаю по етому не получится включит его на master
alter database
-------------------------------------
Jedem Das Seine
25 сен 09, 13:47    [7708184]     Ответить | Цитировать Сообщить модератору
 Re: master + ENABLE_BROKER = Error( 5058 )  [new]
Greenhorn
Member

Откуда:
Сообщений: 311
Maxx,

Гм ... Ну да и ладненько... Буду курочить msdb ...
25 сен 09, 14:02    [7708296]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft SQL Server Ответить