Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Informix Новый топик    Ответить
 Проблема с соединением с базой с удаленных компьютеров  [new]
Сергей Шелест
Member

Откуда: Москва
Сообщений: 96
Имеется Informix Dynamic Server Workgroup v9.30 на Windows 2003 Advanced Server установленый в Домен.
В домене созданы группы Informix-Admin и Informix-Users.
Так вот...
При первом oninit все подсоединяются.
После перезагрузки выскакивает ошибка Informix номер 951:
User username is not known on the database server

пользователь под которым пытаюсь соединиться есть в группе Informix-Users.
Собственно до перезагрузки он спокойно коннектился.
В чем может быть проблема?
Помогите, а то уже 5 день бьюсь.

Все вопросы и решения по проблеме - shelest@grfc.ru
28 янв 04, 10:55    [509991]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
Журавлев Денис
Member

Откуда: St.John,NB,CA
Сообщений: 5532
Права в информиксе с правами вдомене не связаны.

Informix-Admin - дает право администрировать инстанс к данным и базам в информиксе прав не дает.

Сервис от какого пользователя стартует?

Я могу заблуждаться но:
Похоже сначала ты стартуешь информикс от пользователя informix_локального, и ему дают подключится, после рестарта информикс стартует от informix_доменный. Это два разных пользователя. Удали локального пользователя информикс.
28 янв 04, 13:15    [510473]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
anjey
Member

Откуда: Прокопьевск
Сообщений: 930
я может не к месту, но у меня аналогичная проблема..
informix 7.30 на linux, пытаюсь подключиться с виндовой машины, выдает ту же ошибку, 952,
однако тот же юзер, но локально - КОННЕКТИТЬСЯ !!!
что за черт?
29 янв 04, 07:06    [511990]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
Журавлев Денис
Member

Откуда: St.John,NB,CA
Сообщений: 5532
7.30 под Линух ничего не знает про md5(shadow?), очень отключай все нафиг, или информикс возьми по новее.
29 янв 04, 08:43    [512045]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
anjey
Member

Откуда: Прокопьевск
Сообщений: 930
"спасибо" за совет, конечно...
но мне эту версию "спустили сверху" и сказали что это бурундук и он умеет летать
29 янв 04, 09:13    [512065]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
Сергей Шелест
Member

Откуда: Москва
Сообщений: 96
Собственно ставлю бызу под Доменным Админом.
А потом логинюсь под доменным информиксом и сервисы стартуют под доменным информиксом.
Может и ставить и стартовать под доменным информиксом надо?
29 янв 04, 09:15    [512068]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
Журавлев Денис
Member

Откуда: St.John,NB,CA
Сообщений: 5532
автор
Собственно ставлю бызу под Доменным Админом.
А потом логинюсь под доменным информиксом и сервисы стартуют под доменным информиксом.


Так и должно быть. Покажи кусок из %INFORMIXDIR%\online.log
29 янв 04, 10:51    [512264]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
Журавлев Денис
Member

Откуда: St.John,NB,CA
Сообщений: 5532
автор
"спасибо" за совет, конечно...
но мне эту версию "спустили сверху" и сказали что это бурундук и он умеет летать


Отключай shadow и md5 - другого выхода нет.
29 янв 04, 10:53    [512268]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
Daugava
Member

Откуда: Riga-Kiev-Gurzuf
Сообщений: 718
anjey
но мне эту версию "спустили сверху" и сказали что это бурундук и он умеет летать


Проблема была известна еще в прошлом тысячелетии. Вот рецепт из ukr.comp.dbms.informix от Юрика Шестакова (впрочем, это тоже, о чем говорит Денис).

Поредактировать /etc/shadow на предмет DES-криптованного пароля, а не
MD5-криптованного. Если неоткуда сделать DES-криптованный пароль (хотя
это просто подсунуть 2-х символьный salt в ф-ю crypt()), то можно
поправить /etc/pam.d/passwd: Заменить строку

password required /lib/security/pam_pwdb.so use_authtok nullok md5
shadow

на строку без параметра md5:

password required /lib/security/pam_pwdb.so use_authtok nullok shadow

и после этого по-новой сказать `passwd username'

Как альтернативу можно использовать 9-й (2000-й)informix, который от
этой проблемы свободен.
29 янв 04, 10:58    [512289]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
Журавлев Денис
Member

Откуда: St.John,NB,CA
Сообщений: 5532
автор
Как альтернативу можно использовать 9-й (2000-й)informix, который от
этой проблемы свободен.


Игорь, у меня почему-то есть ощущение что последние версии 7.31 тоже свободны от данной проблемы, но я могу ошибаться.
29 янв 04, 11:40    [512412]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
Daugava
Member

Откуда: Riga-Kiev-Gurzuf
Сообщений: 718
Денис, очень может быть. Я сам информикса на линуксе не юзал, а привел пост еще тех времен, когда 7.31 еще не было.
29 янв 04, 12:42    [512595]     Ответить | Цитировать Сообщить модератору
 Re: Проблема с соединением с базой с удаленных компьютеров  [new]
Сергей Шелест
Member

Откуда: Москва
Сообщений: 96
возвращаясь к первому сообщению.

Я поставил все нормально без локальных информиксов и все заработало.
Но потом я поставил на другую машину уже из под глобального информикса с существующими в домене: а) пользователем informix
в) группами InformixAdmin и Informix-Users.

После презагрузки машины первое что меня повергло в шок, так это нестарт Апаче под доменным информиксом.(старт сервиса стоял на автомате именно под доменным информиксом). Вылечилось это переписыванием пароля в закладке Log on сервиса.

Дальше еще смешнее. Опять отказывается пускать пользователей с удаленных машин с ошибкой -951. Но этих же пользователей он пускает на самом сервере(проверено посредством программы Login demo), но уже без пароля.
А с паролем пишет все туже ошибку -951.
SQLHOSTS:
Service - 1526
Protocol - olsoctcp.
Может я чтото не так делаю?
3 фев 04, 10:40    [518235]     Ответить | Цитировать Сообщить модератору
Все форумы / Informix Ответить