Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Oracle Новый топик    Ответить
 Что вы думаете о Out-of-place upgrade starting With 11.2.0.2 [ID 1189783.1]  [new]
_Alex_SMIRNOV_
Member

Откуда: Киев
Сообщений: 1519
Вобщем вопрос в теме. Кто нибудь пробовал так уже апгрейдить сервер?
Появление новых фич в патч-сетах, а не в major release...
25 окт 10, 21:05    [9673325]     Ответить | Цитировать Сообщить модератору
 Re: Что вы думаете о Out-of-place upgrade starting With 11.2.0.2 [ID 1189783.1]  [new]
KIREAL
Member

Откуда:
Сообщений: 390
_Alex_SMIRNOV_
Вобщем вопрос в теме. Кто нибудь пробовал так уже апгрейдить сервер?
Появление новых фич в патч-сетах, а не в major release...


Установил на тестовый кластер, без каких либо проблем...

За исключением одной: при выполнении скрипта root.sh попросил установить патч 9655006.

По времени выходит тоже самое - установка GRID минут 5-10, выполнение root.sh минуту полторы (для CRS)... Перезапуск CRS из нового хоум, установка ORA_HOME минут 5-10, выполнение root.sh, ну и собственно патч словаря данных.

Новые фичи это хорошо, где бы взять времени со старыми разобраться

Из интересного, что мне пригленулось:

1. Truncate
2. Default Size of First Extent of Any New Segment for a Partitioned Table Has Changed (64KB -> 8M)
(Хотя каждый сам мог создать TS с опцией uniform extent)
3. Сервисы с EDITION опцией - пример использования: создание разных сервисов для "тестировщиков" и продакшена (жестокий случай разработки - но такие по всюду)

4. Ну и конечно Quality of Service (QoS) Management.

Там еще что то с секционирование и DBMS_SPACE проапгрейдили, но я не смотрел еще.
26 окт 10, 08:08    [9674361]     Ответить | Цитировать Сообщить модератору
 Re: Что вы думаете о Out-of-place upgrade starting With 11.2.0.2 [ID 1189783.1]  [new]
Romes
Member

Откуда:
Сообщений: 142
при установке 11.2.0.2 получил предупреждения:

This is a prerequisite condition to test whether the OS kernel parameter "tcp_smallest_anon_port" is properly set. (more details)
Expected Value
 : 9000
Actual Value
 : 32768


This is a prerequisite condition to test whether the OS kernel parameter "tcp_largest_anon_port" is properly set. (more details)
Expected Value
 : 65500
Actual Value
 : 65535


This is a prerequisite condition to test whether the OS kernel parameter "udp_smallest_anon_port" is properly set. (more details)
Expected Value
 : 9000
Actual Value
 : 32768


This is a prerequisite condition to test whether the OS kernel parameter "udp_largest_anon_port" is properly set. (more details)
Expected Value
 : 65500
Actual Value
 : 65535


если были такие сообщения, обращали ли на них внимание, стоит изменять? в новой версии видимо новые требования.....
26 окт 10, 11:57    [9676215]     Ответить | Цитировать Сообщить модератору
 Re: Что вы думаете о Out-of-place upgrade starting With 11.2.0.2 [ID 1189783.1]  [new]
Edward Shevtsov
Member

Откуда: Moscow
Сообщений: 13469
_Alex_SMIRNOV_,

Grid Infrastructure можно проапгрейдить только через out-of-place patch set upgrade. При этом для линуксовых версий необходим предварительный накат GI PSU2. Забавно в общем.
7 ноя 10, 00:19    [9737352]     Ответить | Цитировать Сообщить модератору
 Re: Что вы думаете о Out-of-place upgrade starting With 11.2.0.2 [ID 1189783.1]  [new]
Edward Shevtsov
Member

Откуда: Moscow
Сообщений: 13469
http://surachartopun.com/2010/09/struggle-to-upgrade-oracle-database.html
9 ноя 10, 05:00    [9745429]     Ответить | Цитировать Сообщить модератору
 Re: Что вы думаете о Out-of-place upgrade starting With 11.2.0.2 [ID 1189783.1]  [new]
Edward Shevtsov
Member

Откуда: Moscow
Сообщений: 13469
http://www.dba-village.com/village/dvp_forum.OpenThread?ThreadIdA=41647

Then, i think there is a big mistake in both script :

Replace all
“if [ oracle = "root" ]”
by
“if [ $HAS_USER = "root" ]”
and
“HAS_USER=oracle”
by
“HAS_USER=root”
in /etc/init.d/ohasd and /etc/init.d/init.ohasd.

Run "rootupgrade.sh" again and it will work ...


за-ши-бись
9 ноя 10, 09:27    [9745814]     Ответить | Цитировать Сообщить модератору
 Re: Что вы думаете о Out-of-place upgrade starting With 11.2.0.2 [ID 1189783.1]  [new]
Alex Roudnev
Member

Откуда: Валнут Крик, Калифорния
Сообщений: 5547
Edward Shevtsov
http://www.dba-village.com/village/dvp_forum.OpenThread?ThreadIdA=41647

Then, i think there is a big mistake in both script :

Replace all
“if [ oracle = "root" ]”
by
“if [ $HAS_USER = "root" ]”
and
“HAS_USER=oracle”
by
“HAS_USER=root”
in /etc/init.d/ohasd and /etc/init.d/init.ohasd.

Run "rootupgrade.sh" again and it will work ...


за-ши-бись


Красиво! Индусские боги!

Впрочем я уже видел

PROCD_DISABLE=true
означало _ЗАПУСТИТЬ PROCD_

Оракл погубят индусы!
9 ноя 10, 23:47    [9751262]     Ответить | Цитировать Сообщить модератору
Все форумы / Oracle Ответить