Добро пожаловать в форум, Guest  >>   Войти | Регистрация | Поиск | Правила | В избранное | Подписаться
Все форумы / Microsoft SQL Server Новый топик    Ответить
 WinCE 4.20 и SQL Client 2.0 не могу совместить, проблема соединения с сервером  [new]
vityugan
Member

Откуда:
Сообщений: 6
Проблема простая, мной написана прога для Symbol-Motorolla терминалов. У нас их много, версии OS разные от 2003 до Мобайла и CE5. везде поставилось хорошо, и все работает нормально, но вот терминалы Symbol9060 с WinCE 4.20 net не знаю как запустить, все на него ставится отлично, все работает, кроме запросов к серверу. Точнее даже не запросов, connect.Open не дает соединения. Что делать не могу придумать.
Похоже тут дело в несовместимости. Как решить данную проблему????? Блин засада какая-то.

Если есть хоть какие-то мысли напишите, у меня все закончились, решить вопрос пытался уже 3 раза с интервалом во времени.
11 ноя 11, 12:45    [11580854]     Ответить | Цитировать Сообщить модератору
 Re: WinCE 4.20 и SQL Client 2.0 не могу совместить, проблема соединения с сервером  [new]
Glory
Member

Откуда:
Сообщений: 104751
vityugan
Точнее даже не запросов, connect.Open не дает соединения. Что делать не могу придумать.

Прочитать сообщение об ошибке для начала ?
11 ноя 11, 12:50    [11580902]     Ответить | Цитировать Сообщить модератору
 Re: WinCE 4.20 и SQL Client 2.0 не могу совместить, проблема соединения с сервером  [new]
trew
Member

Откуда: Москва
Сообщений: 2646
vityugan,

Может Wi-fi не настроен. Еще есть сайт тех. поддержки по терминалам Motorola (Symbol).
11 ноя 11, 13:08    [11581087]     Ответить | Цитировать Сообщить модератору
 Re: WinCE 4.20 и SQL Client 2.0 не могу совместить, проблема соединения с сервером  [new]
vityugan
Member

Откуда:
Сообщений: 6
trew
vityugan,

Может Wi-fi не настроен. Еще есть сайт тех. поддержки по терминалам Motorola (Symbol).


все настроено, на всех терминалах идентично 2003 CE5 VM5 CE4.20
не работает только на CE4.20
11 ноя 11, 14:17    [11581854]     Ответить | Цитировать Сообщить модератору
 Re: WinCE 4.20 и SQL Client 2.0 не могу совместить, проблема соединения с сервером  [new]
vityugan
Member

Откуда:
Сообщений: 6
Glory
Прочитать сообщение об ошибке для начала ?


Message = "PlatformNotSupportedException"
11 ноя 11, 14:34    [11582048]     Ответить | Цитировать Сообщить модератору
 Re: WinCE 4.20 и SQL Client 2.0 не могу совместить, проблема соединения с сервером  [new]
Сергей Мишин
Member

Откуда:
Сообщений: 376
vityugan,

Может не в "тему", но как то очнь давно писал клиента под WinCE 4.2, тогда тоже были проблемы. Подробностей уже не помню, но суть в том, что соединение валилось при обращение к БД с collation Cyrilic..., а к Latin... нет.
11 ноя 11, 19:55    [11585000]     Ответить | Цитировать Сообщить модератору
 Re: WinCE 4.20 и SQL Client 2.0 не могу совместить, проблема соединения с сервером  [new]
pkarklin
Member

Откуда: Москва (Муром)
Сообщений: 74927
Сергей Мишин,

+100500

Это актуально и сейчас. Пришлось создавать промежуточную бд. И если символьные поля в бд не юникодные - есть проблемы с русским языком. Решаются явным кастом в юникод.
12 ноя 11, 11:57    [11586515]     Ответить | Цитировать Сообщить модератору
 Re: WinCE 4.20 и SQL Client 2.0 не могу совместить, проблема соединения с сервером  [new]
Firebird ADO.NET Edition
Guest
pkarklin
Сергей Мишин,

+100500

Это актуально и сейчас. Пришлось создавать промежуточную бд. И если символьные поля в бд не юникодные - есть проблемы с русским языком. Решаются явным кастом в юникод.


это означает, что невозможно без промежуточной БД общаться с БД (неанглийская кодировка) из сканера с английским образом?

мама, роди меня обратно!
8 авг 12, 19:51    [12984195]     Ответить | Цитировать Сообщить модератору
Все форумы / Microsoft SQL Server Ответить